Accessing old RAID-0 data

May 5, 2009 at 16:52:09
Specs: Windows XP
I have an old KR7a Raid motherboard with a highpoint 370/372 controller that failed on me. I upgraded to a newer motherboard (ABIT M2V-MX-SE). Actually the hard drive with the OS failed and reinstallations of the OS didn't work ... I could never get it to load the OS properly.

My old setup I had two 160 GB WD Hard drives set up in a RAID-0 configuration. The old motherboard had a highpoint 370/372 RAID controller built in.

The data is still intact on the two 160 GB hard drives but it's in RAID-0 and I cannot access it.

I've tried buying a highpoint raid controller but found out that in order to access the data I had to have the same old highpoint 370/372 raid controller in order to get to it.

I bought a KT7A Raid motherboard (with the highpoint 370/372 controller) but an electrical problem shorted it out (had the monitor plugged in one outlet and the computer plugged in a different outlet and got an electrical shock when I connected them... turns out they were on different circuits and somehow didn't like being crossed... but the raid hard drives were not installed at the time so no worries there). I tried buying another KR7a Raid motherboard recently but that one arrived DOA. Grrrr.

What I'm trying to find out is if there is any other way to access the data without having to buy yet another motherboard with the highpoint 370/372 controller built in? i.e. could it be done with drivers and such? If not, do you have any suggestions?

Thanks for any help you might be able to provide. I've got lots of video and pictures on those drives I'd like to save.


See More: Accessing old RAID-0 data

Report •

May 5, 2009 at 19:21:01
I doubt it is a soft raid. Could try ubuntu cd and see if it can read a single disk.

Not sure why you need that exact model raid chip. Pretty old stuff. Might find one cheap somewhere.

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

May 7, 2009 at 08:02:59
Thanks for the reply. I was finally able to access my data. I found a faulty DRAM chip and got the old MB working. I used a Knoppix CD to access the hpt37x controller and was able to transfer it all to my external USB HD.

Report •

Related Solutions

Ask Question