Solved Access denied on all objects retrieved from WD My Passport

March 26, 2015 at 05:36:18
Specs: Windows 7, 6gb
Having cause to rebuild my Sony Vaio laptop from scratch I encountered problems trying to access any object retrieved from the external WD My Passport hard drive backup. The objects were all correctly restored in their original folders on the C drive and appear to have security permissions which give full control to me as the administrator. No object has access denied ticks set for any user. Objects when backed up were not encrypted.

See More: Access denied on all objects retrieved from WD My Passport

Report •

March 26, 2015 at 06:04:42
Have you tried taking ownership of the files?

Report •

March 26, 2015 at 06:18:16
I checked several objects and all claimed that I (as the administrator) was already the owner.

Do I have to apply re-ownership to gain access, if so how is this done?

There is obviously an issue here that nobody has successfully resolved by applying standard Windows options judging by the number similar postings I have viewed.

Report •

March 26, 2015 at 08:26:26
✔ Best Answer
Try following this procedure:

The problem may be that, having reinstalled Windows you have created new users. They may have the same readable names as before, but Windows identifies a user not by name but by SID (security identifier) which is unique numbers that looks like: S-1-5-21-1180699209-877415012-3182924384-500

This means that a user named "John" on one Windows setup is totally different from a user named "John" on another one. Anyway, it's worth a try with one file to see if it solves the problem.

Report •

Related Solutions

March 26, 2015 at 10:04:55
You are absolutely right. A guru close friend of mine provided me with the means to take ownership as me now even though the admin names were the same.

Problem solved - thanks for your help and clear explanation.

Report •

Ask Question