AC Adapted not Detected After Startup

November 8, 2012 at 00:13:03
Specs: Windows XP, Atom N450 / 2GB
Netbook powers on with AC adapter, and battery charges just fine.

However, once the AC adapter is removed, and the computer is running on the battery, it will no longer detect the AC adapted when I plug it back in.

Thus, even with the power cord plugged in, the netbook will run off of the battery until it eventually shuts down due to low battery status.

In order for battery to charge, I need to shut down the PC, remove the battery, turn on the computer with the AC adapter plugged in, and then insert the battery.

I tried a different AC adapter, same result.
I replaced the power jack (solderless), same result.

When the computer is running off of the battery and I plug in the AC Adapter, it should switch over to AC power, but it doesn't. And the battery does not charge.

The Netbook is about a year old. The battery has been losing a little bit of its longevity, but seems to be working just fine.

Battery issue? Motherboard issue? BIOS issue? any ideas?

A new battery is $30, and I don't want to buy it and waste that money if its not the problem.

See More: AC Adapted not Detected After Startup

Report •

November 8, 2012 at 00:54:53

Disconnect the AC adapter from the computer and check AC Adapter LED.

If LED is on, then try resetting the system BIOS to factory defaults.

Thanks & Regards
Debbie B

Report •

November 9, 2012 at 08:06:58
With the computer off, if I plugin the AC adapter first, and then plug in the battery, the LED for "battery charging" will turn on. When I unplug the AC adapter, that light goes off.

HOWEVER, the problem is that when I try to plug the AC adapter back in, the "the battery charging" LED does not come on.

This is all without even booting up the PC.

So, my computer doesn't really have an "AC Adapter LED" it only has an LED that indicates the battery is charging.

With all of that said, I did update my BIOS in attempts to solve the problem, and it did not have any effect.

Also, I just completely erased my HDD (I'm in process of installing a new OS from scratch). The problem still exists, so I know it has nothing to do with any battery management software. Its either the BIOS, Battery, or Motherboard.

I will try and bring my BIOS back to factory settings and let you know if that changes anything.

Thanks for the response!

Report •

November 9, 2012 at 21:06:01
I just wiped my cmos and reset the bios. I'm still having the same issues. This must be a motherboard issue.

Any other thoughts?

Report •

Related Solutions

November 11, 2012 at 18:44:42

This might be the issue with the Ac Adaptor port. If your system is under warranty, get the motherboard replaced or you can get it repaired in local.

Thanks & Regards
Debbie B

Report •

Ask Question