5.25" floppy drive

September 1, 2009 at 07:41:52
Specs: Windows 98 SE, 501 mhz / 192 mb
I took this old 5.25" floppy drive out of an old computer i had and then put it into my windows 98 machine and went in to the cmos to tell it that there was a drive in the B:\ slot. So then i finished booting up the computer and went in to my computer and saw that it reconized the drive was there so then i put in a floppy that i knew worked. and it read it and ran it. So i used that disk and others and just fished around looking what was on these disks. So then i started it up again the next day and it worked fine. But the third time i went to boot up the system it booted normally but then i went to run the disk, and with the disk in the drive it cave me an air warning of B:\ is not accesible. The device is not ready. Which is the responce you normally get when you have no disk in the drive. So then i tried unistalling and re intalling the drive and nothing worked. So then i put the drive back in the computer i got it out of and it worked and read the disks fine. So do you know why it would of stoped and what i could do to fix it?

See More: 5.25" floppy drive

Report •

September 1, 2009 at 09:30:06
Have you already cleaned the read/write head of the drive.
The most common problem on 5.25" drives is dirt on the read/write head.

It starts with:
1 it works
2 it works sometimes
3 it doesn't work

Please send a reply, if you solved the problem !!!

Report •

September 1, 2009 at 11:34:21
Yeah, make sure it's clean. Blow out any dust with compressed air and wipe the heads with windex or alcohol on a Q-tip.

360 K and 1.2 M drives look the same. It must have been ID'd right in cmos else you'd have gotten a bios floppy error message. Still, that's something to check. What's the drive model number?

Those 5.25 drives usually had a removable terminating resistor if it was to be used as the drive on the end of the cable. Since it's your B: drive I assume it's on the center connection. If so you can remove that resistor (if it's there). Also check the DS jumpers. There's some info here:


One thing I would add to the link; DS jumper go from DS0 to DS3 or from DS1 to DS4. With a twisted cable set it to the second setting--DS1 or DS2 depending on how they're numbered.

Report •

September 1, 2009 at 15:05:36
Okay to start with the drive works on an old ASUKF machine running dos 3.0. and in that machine the drive always worked
But then when i put it into a newermachine running 98 it worked fine for the first two power ups but not the thrid. The model number of the drive is M4851-112U amd it is dated march 1984 finally it is a Mitsubishi mini flexible disk drive. I tried to clean the heads. and a nother question where would i find the terminal resistor. Becasue the site you direcded me to said that the resistor should have some marking on the resistor somthing like t r or t res. Thanks though

Report •

Related Solutions

September 1, 2009 at 15:15:45
As was stated above your disk may be different types.

Plus if they were recorded on different drives that could be a problem too. Those old floppy drives had problems with head alignment. If you have some long cotton swabs on a stick use some rubbing alcohol to clean the heads. You can see them from the front but they are beck in a ways.

Report •

September 1, 2009 at 22:01:45
That model is a 360 K drive so it's not going to read disks formatted to 1.2 meg. And make sure it's identified as a 360 in cmos/bios setup and not as a 1.2.

For the terminating resistors, the DIP type looked something like a basic IC chip, say a 7400:


but was usually yellow in color. Here's a pic of the SIP type:


The actual number of pins your terminating resistor has may vary from the pics but should be close.

Oh, and the terminating resistor is usually physically located very close to the slide-on cable connection on the drive's circuit board.

Report •

September 2, 2009 at 05:49:27
So i went back in to the bios and confirmend that it was set as a 5.25" 360k and it was then i also remeved what it think was the terminal resistor and it still works in the dos machine but when i put it back into my win 98 se machine , the divice maniger still show the drive bieng there and working properly. and then i go into my computer with the disk in the drive and tell it to run the drive turns and the head moves back and fourth really quikly (faster that it does when it works or in the dos machine) and still gives me the warrning the device is not ready. is it posible i need a driver for the drive?

Report •

September 2, 2009 at 06:04:42
What is it you are trying to recover? There should be a couple of methods to transfer the data from the old DOS computer to somewhere else. Depends on what is available on the DOS machine.

If you are simply experimenting with 5 1/4 drives then get a newer one that can read higher density disks.

Keep in mind that disks written 25 years ago may not yeild any useful data anyway. The media deteriorates and magnetic fields can erase the data.

Report •

September 2, 2009 at 07:05:33
So thanks anyways thats okay that it did not work.
im still confused for why it worked for a little while then stoped.

Thanks again

Report •

September 2, 2009 at 20:51:35
Use F8 when starting up to get the boot menu. Try both safe mode and command prompt only. Then see if previously unreadable disks work OK.

Number 6 here:


maintains 5.25 support in 98 is just flakey but the dos method above should work.

Also check the last few posts here:


One indicates altering the DS jumpers may help. Another says it has to do with the signal sent by the drive on pin 34 that is misinterpreted by modern floppy controllers.

Report •

September 2, 2009 at 21:55:52
There is a floppy driver update for 98. It applies to situations where 'Floppy Disk May Be Unreadable or Computer Hangs with LS-120 Drive'. The only download site I could find was here:


Give that a try. Even if it doesn't help you're not going to hurt anything by installing it.

Report •

September 4, 2009 at 05:31:55
Thank you so much for giving me that driver. it works again


Report •

September 4, 2009 at 16:34:23
You're welcome. I'm glad it worked out.

Report •

September 4, 2009 at 17:04:24
Thanks for that file Dave. I had no copy of it anywhere.


Report •

September 4, 2009 at 17:24:58
You're welcome. I guess that's one of the more obscure updates that most 98 sites don't have.

Report •

Ask Question