Solved 486 TURBO LED Not changing?

Gateway 2000 / G6-180
December 28, 2014 at 17:50:48
Specs: Windows 3.11, 486
I have a 486-66 with a turbo button and lcd showing the Mhz. When I flip the turbo switch, the LCD does not change. It always says 66. The LCD Mhz display is full of jumpers on the other side. Is this a fake display or is it broken. Shouldn't it change from 66 to 33 and vice-versa? Just wondering.

thnx

"Like car accidents, most computer problems are due to driver error."

message edited by 486guru


See More: 486 TURBO LED Not changing?

Report •


✔ Best Answer
December 29, 2014 at 07:55:10
Again, the display is likely "hard-wired" to show "66". If you remove one of the jumpers, then you'll likely see one of the segments disappear. There were very few "smart displays" that actually determined the speed of the CPU. If you replaced your 486/66 with something like a 486/33, it'd still display "66"....

"Channeling the spirit of jboy..."



#1
December 28, 2014 at 21:30:12
Bigger question is if you notice any difference with the performance of the machine with the button pushed/released. Most older machines had a MHz display locked with a jumper setting(s) inside the case (as you mention), especially if it's an LED display (not LCD as you state). A diagnostic utility such as Norton Utilities (or perhaps even MSD, included in DOS 5 or above) would likely tell you the speed the machine was running as well. Also, if it truly has a turbo speed, it may be that when it's not in turbo it's running more like 8MHz (to accommodate older "speed-locked" DOS games).

"Channeling the spirit of jboy..."

message edited by T-R-A


Report •

#2
December 28, 2014 at 21:30:35
You need to open it up and see how the wires are connected. Check the turbo sw and turbo led connections. Sometimes you'd just put a jumper across the turbo switch pins on the motherboard so it was always turbo and the button on the front panel wouldn't even be connected to anything.

It's also possible the motherboard doesn't have a turbo pins. Someone may have used an old 286 case and put a 486 board in it. Then you'd experiment with the jumpers on the back of the LED display until you got it to show the numbers you want to see.


Report •

#3
December 29, 2014 at 07:28:06
What I meant top say was isn't the LCD display on the front supposed to change to show the Hi/Low setting of the Mhz when you flip the turbo switch? I don't mean the LED that turns on and off, I mean the LCD display that shows the Mhz. It always says 66 even when the switch is in de-turbo mode.

"Like car accidents, most computer problems are due to driver error."


Report •

Related Solutions

#4
December 29, 2014 at 07:55:10
✔ Best Answer
Again, the display is likely "hard-wired" to show "66". If you remove one of the jumpers, then you'll likely see one of the segments disappear. There were very few "smart displays" that actually determined the speed of the CPU. If you replaced your 486/66 with something like a 486/33, it'd still display "66"....

"Channeling the spirit of jboy..."


Report •

#5
December 29, 2014 at 17:40:12
Yeah we know what display you're talking about. The ones I've seen are LED--red numbers on a black background--but I suppose some could be LCD.

What it displays depends on how the jumpers on the back of it are configured. And since you never get paperwork on what that configuration is, anytime you swap in a motherboard with different speeds you can only randomly experiment to see if you get it to show the right numbers. And then even if you get the turbo to show right you have to try again with the non-turbo speed. I don't recall ever getting both to show the right speed.

And I as mentioned before, the turbo pins could be jumpered so it's always turbo or there may be no turbo pins. In that case it could still show a speed there as the display is powered directly from the PSU.


Report •


Ask Question