320Gb HD thinks its a80Gb HD

March 14, 2011 at 12:37:51
Specs: Windows XP
Copied MBR from 80Gb HD to A 320Gb HD. Now 320Gb 'thinks' it's a 80Gb HD. The 320GB HD is a WD3200bEVT HD. What info would I place in the first secto to correct this?

See More: 320Gb HD thinks its a80Gb HD

Report •

March 14, 2011 at 12:55:34
If you have a Windows CD, boot from it and run fixmbr in the Recovery Console. Ignore the warning message you may get when you run that command.
(Press R at the first screen where you are asked if you want to Repair Windows.
Usually there is no Password - just press Enter.)

What else did you copy ? Is the whole capacity of the drive being seen ?
If only 80gb (or less) is being seen, you can only fix that without losing the data on the partition by using a third party "partition manupulation" program, such as the freeware Easeus Partition Master Home Edition

XP must have at least SP1 updates installed in it in order to recognize drives or drive partitions larger than 137gb manufacturer's size = 128gb binary in the bios and in Windows..
If the XP CD you use has no SP updates at all, it can't recognize drives or drive partitions larger than 128gb binary. In that case, you need to make yourself a "slipstreamed " CD that has the SP3 updates integrated into it.. Instructions for how to do that are plentiful on the web, Then you use that "slipstreamed" CD as your Windows CD, and your original Product Key can be used with that CD, if you need to.

Report •

March 14, 2011 at 14:18:08
I was trying to replace a small drive a larger one. When installed clone to larger drive I was prompted 'Do you want to copy MBR' I answered yes. Bad move.... Therefore my present issue. Tried what you indicated. WD Tech support recommended writing zeroes on the drive, no luck. I may be stuck with a 80Gb HD and not the 320Gb I used to have..

Report •

March 14, 2011 at 14:44:48
Read ALL of response 1.
Answer the questions.
Comment on what I said.

You CAN fix your problem.

"Tried what you indicated."

What was the result ?

Fixing the mbr won't make a partition on the 320gb drive larger.


You can use free software (drive preparation programs) available on the web site of either drive brand to copy the entire contents of the 80gb drive to the 320gb drive, and you can have it make larger partitions on the larger drive while you're doing that.

E.g.Seagate has Maxblast and another one that can be used if you have a Seagate or Maxtor hard drive; Western Digital has one.
The Seagate ones must be installed on the original drive, or you can install them on any computer and then make a Dos bootable CD of the Dos version that can do the same things.
The Seagate Maxblast and the one Western Digital has are slightly crippled versions of Acronis software - you can copy an entire drive's contents but not the contents of an individual partition. You are not asked if you want to copy the mbr of the original drive.

Report •

Related Solutions

March 15, 2011 at 00:33:39
You can try cloning it again without copying the MBR but that might not change anything since the wrong MBR is copied there already.

It's not a SATA drive, is it? You can try running the recovery console after booting from the XP cd:


and then running FIXMBR. I'm pretty certain you don't need sp1 for that.

Or boot up with a 98 disk and at the prompt type FDISK/MBR and enter. If you use that command run it twice. For some reason it sometimes doesn't 'take' the first time.

Either command overwrites the current MBR with a fresh copy.

If a doe and a mare eat oats what does a lamb eat?

Report •

March 15, 2011 at 04:34:47
Watch the POST screens when first starting up, to see if the BIOS is configuring your hard drive by both the correct model and the FULL capacity.

Without any system specs I can only guess, but your BIOS may not be 48 bit LBA compliant. IF that is the case then you have a different set of problems to deal with.

Report •

March 15, 2011 at 04:55:08
If you go into Disk Management and check there. I would bet that there is an 80 Gb drive and 240 Gbs of unallocated space.

If the original was 80 Gbs and it was copied using the original MBR then the destination will also be 80 Gbs, regardless of the size of the destination which in these circumstances, is irrelevant.


Report •

March 15, 2011 at 14:45:07
I truly appreciate all the assistance. I should've been more clear in my post. I have a Gateway MS2273 with a fried M/B. The HD is a WD3200BEVT. Figured I would swap HDs with an older Dell Inspiron 80Gb. Using WD Acronis I cloned the 80Gb and migrated it to the 320Gb HD.
I remember being asked long the lines of 'Do you want to copy the MBR' I said yes.
Next thing I know my 320 Gb is an 80Gb. Disk Management indicated 2 partitions a 1.2GB Utilities and a 73Gb System with no unallocated space. WD Support had me write all zeroes to the drive and format. It still shows as an 80Gb HD. I tried to recover the 320Gb partition info with 3rd party software(Paragon Disk Doctor and a Easeus product), it appears that I deleted the backup MBR that should be in the middle or tail end of the HD's sectors. Again, I truly appreciate yall's assistance.

Report •

March 15, 2011 at 15:19:09
You still didn't answer the question of how does the drive show in the BIOS and POST screens?

Report •

March 15, 2011 at 16:00:13
BIOS detects a WD3200BEVT HD and when I go to select boot drive menu I see the same thing WD3200BEVT. I feel that I have 1 of 2 choices, Stay with a 80Gb HD or learn how to edit the MBR with 'correct' info.

Report •

March 15, 2011 at 16:16:34
Do you have at least SP2 installed on the 80GB?

Have your tried the FIXMBR command? Look at the link just below.


If that is not possible because you don't have a WinXP CD then try the following. If you still have the 80GB then I suggest you use the Western Digital version of
Acronis True Image WD Edition Software. That can be downloaded from the Western Disgital site.

Report •

March 15, 2011 at 16:29:45
Data Lifeguard Tools software (Acronis True Image WD Edition and the WD diagnostic tool)


Page 91

Wrong capacity of cloned hard drive

Refers to:

1710: HPA Makes the Cloned Drive Display Wrong Capacity

Was the drive you copied a drive in DELL system by any chance?
If so, they sometimes have that HPA

Report •

Ask Question