1 partition of USB drive is showing as CD-ROM (can't format)

September 10, 2020 at 19:20:13
Specs: Windows 10
Hello!

I have a 16 GB usb pen drive, which has 2 partitions. One of the partition is showing as CD-ROM and is only readable. Another partition is like usual usb drive and is read/writable (also can be formatted).

Now, I want to format and combine both the drive into one but the first drive is showing as CD ROM and can't be formatted.

Here is what I have already tried:

1. Tried to format using Disk management tool (Windows 10). But as the first partition is detected as CD-ROM, it's impossible to format.

2. Tried Diskpart in command prompt. But only the second partition is visible there so the first partition remains untouched.

3. Tried Easus Partition Master, but didn't get ayy way out (as the partition showing as CD-ROM is not visible there too).

4. Also tried in Linux system, but no result.

Thanks for help in advance!

Regards!

Jhambu

message edited by Jlal


See More: 1 partition of USB drive is showing as CD-ROM (cant format)


#1
September 11, 2020 at 05:49:08
Here is more to try.

Malvastyle USB Repair
https://www.softpedia.com/get/Syste...
https://malvastyle.com/disk-repair-...
https://www.youtube.com/watch?v=hZp...

How to Repair a Corrupted USB Drive in Linux
https://www.maketecheasier.com/repa...
Write Protected USB Format Tool Free Download: Format Read-Only Device Easily
https://www.diskpart.com/articles/w...
Fix/Repair Corrupted USB Flash Drive/Pen Drive without Formatting
https://www.easeus.com/storage-medi...
How to Fix a Broken USB Stick and Recover Data
https://www.easeus.com/resource/how...
How To Repair Corrupt USB Flash Drive
http://www.toptrix.net/2013/01/repa...
Apacer USB 3.0 Repair Tool: All You Need to Know about It
https://www.anyrecover.com/external...
https://www.softpedia.com/get/Syste...
This USB repair tool can effectively fix any USB drive even if it’s write protected, it fixes storage devices by restoring and formatting them.

How to force format a USB device?
https://ubuntuforums.org/showthread...
Flash Drive Repair Tool
http://getmediayoutube.com/watch?v=...
https://www.youtube.com/watch?v=hZp...
http://malvastyle.com/removable-usb...
Repair Flash Drive Write Protect, RAW, Unformated and corrupt
https://www.youtube.com/watch?v=GpG...

message edited by Johnw


Reply ↓  Report •

#2
September 11, 2020 at 09:45:34
Delete the partitions, create a new partition using all available unallocated space, then format.

Reply ↓  Report •

#3
September 11, 2020 at 23:13:41
I'll try one-by-one and revert back here ! thanks

Reply ↓  Report •

Related Solutions

#4
September 11, 2020 at 23:14:40
@Johnw ! I'll try one-by one and revert back here. Thanks !

Reply ↓  Report •

#5
September 11, 2020 at 23:16:41
@riider !Thanks but deleting option is not there ! :)

Reply ↓  Report •

#6
September 12, 2020 at 11:07:04
Open Disk Management. The USB stick should be labeled something like Disk # Removable. Right click on one of the partitions...is "Delete Volume" an option? If it is, do that to ALL of the partitions until you have nothing left but unallocated space.

BTW, you never mentioned the make/model of this stick. Some come with software preinstalled that might have to be removed. The manufacturer's site might have a tool for that.

A couple of sites I found:
https://www.techwalla.com/articles/...
https://www.bleepingcomputer.com/fo...

message edited by riider


Reply ↓  Report •

#7
September 12, 2020 at 22:16:52
@riider!
1. I've mentioned above in disk manaement it is labled as CD-ROM and when I right click it ther is no option for delete or format.

2. Yee, it's Sandisk 16 GB usb drive.
3. Went through teh links and was not helpful.

Thanks!


Reply ↓  Report •

#8
September 13, 2020 at 00:24:16
"3. Went through teh links and was not helpful"
I didn't like to discourage you, but I also was unable to get my 8gb Sandisk working.

Reply ↓  Report •

#9
September 13, 2020 at 07:28:12

Reply ↓  Report •

#10
Reply ↓  Report •

#11
September 18, 2020 at 02:49:45
I had a similar problem with an usb-drive so I hope that your answers can solve my problem.
Will try it!

Thanks in advance


Reply ↓  Report •

Ask Question