Solved Why can I only play games that are on C: ?

January 22, 2017 at 01:19:30
Specs: Windows 7, Core i3 2.2GHz / 2 gigs
So before I installed a new Windows 7, games on all disks C:, D:, E: could be play. But now after installing it, I can only run games on C: and D: . When I try to run games on E: (about 2,3 games), all get errors (mainly stopped working after clicking them). No matter how I try to reinstall those game on E: , they're still can't be played. Any solution to this problem? It's pretty annoying because my C: has little space, but D: and E: have a lot of space.

See More: Why can I only play games that are on C: ?

Report •

#1
January 22, 2017 at 02:25:49
✔ Best Answer
@headhunter

At First Step Check Your Hard Drive For Errors.
http://www.addictivetips.com/window...

Then Check The Permission & Ownership Status.
http://www.addictivetips.com/window...

(Suggestion : Compare Permission & Ownership Status Defined For Each Drive)

Good Luck

message edited by TechDOS


Report •

#2
January 22, 2017 at 06:26:05
It would help if you'd explain why you "installed a new Windows 7", the size of your HDD, the size of the individual partitions, & why you didn't address the almost full C: partition during the process.

When you reinstall your games, you will have to direct them to install into the same folders in the same partitions as the prior Win7 installation. They will overwrite the files in the folders. Your saved games may or may not remain untouched.

On a side note, I can't imagine your games play all that well with only 2GB RAM.

message edited by riider


Report •

#3
January 22, 2017 at 07:58:44
Did you reinstall these games on E: after reinstalling Windows 7? If not, you're probably missing some of the game's registry information, and various versions of the C++ runtime and DirectX DLLs.

How To Ask Questions The Smart Way


Report •

Related Solutions

#4
January 22, 2017 at 23:43:38
Enable read-write access on your drives, seems like that's the only cause.

https://www.uwec.edu/help/drives/pe...

Regards,
Jay Sarma
Music Producer and Game Developer
Dibrugarh, Assam, India
http://www.jaysarma987.tk


Report •

#5
January 23, 2017 at 19:46:57
Well, I reinstalled Windows 7 because my old one was in bad conditions (lag, viruses and more things that annoyed me). I downgraded from Ultimate to Professional because I only had Professional at that time. All I did was format C: and then install a new one.

I have tried to reinstall the game, but it doesn't seem to work. With 2GB RAM, I usually play games with lowest quality (I'm playing GTA IV, League Of Legends, Goat Simulator...)

I haven't tried to do something with the permission things yet, I will do that when I finish downloading my new game xD


Report •

#6
January 25, 2017 at 03:18:43
I believe the permission is the problem. I changed the permission the same as it was in C: and now I can play my new game installed on E:

Report •

Ask Question