starcraft 2 videocard error

Havas Starcraft ii: wings of liberty
July 30, 2010 at 15:11:31
Specs: Windows Vista
I have a problem running starcraft 2. I get an error message stating

The videocard is not accessible because no display drivers are installed, another 3D application has exclusive access or the machine was locked. Please close any 3D applications or games and try starting StarCraft II again. If the problem persists, for more information consult our support website at <a href="</i>" target="_blank">

the website was ueseless, I'm worried my videocard isn't up to the task as its the oldest part of my PC.

Vista premium
Core 2 quad cpu 2.66GHz (4 cpus)
4 gigs of DDR2 Ram
Asus P5Q-EM mother board
Radeon X1800 series video card running dual monitors

I updated the drivers to the latest available from ATI, do I just need a new videocard? or is there something I can do with the videocard I have.

Thanks for the help.

See More: starcraft 2 videocard error

July 31, 2010 at 07:34:18
Did u know u have a nice system?
Throw that piece of crap (x1800) and buy yourself a nice video card. For eg. If u buy ati radeon hd 5770 u will be able to play newer games with high settings + eye candy.
But x1800 isn't a issue, start craft 2 has low system requirements.

Report •

July 31, 2010 at 10:15:11
thanks, I got the X1800 to work. Most of my stuff is from when I was working for Intel and it was an initial test chip. Now I'm a student, but it sure makes going to school online easier with 2 monitors and a fast computer.

Report •

July 31, 2010 at 11:32:36
what did you do to get it to work? I am getting the same error message. I am sure that my video card is not the issue, and I have the latest drivers installed, and I am at a loss for what else to try

Report •

Related Solutions

July 31, 2010 at 13:28:55
"what did u do to get it to work?"
check this out

Report •

July 31, 2010 at 13:30:34
in vista, click the window button, then put the mouse over computer

right click and select properties

Then use the device manager task

hit the plus for display adapters, and ensure you do not have on board video card enabled, only the sub header for your video card.

then double click the video card name, and under the driver tab, hit the update driver button. That is what fixed it for me, even though I downloaded the new drivers a couple days before.

the link above is a thread I started on starcraft forums.

Report •

December 5, 2010 at 02:47:37
i have this same problem,,, and it wont fix for me and everything is fine :( i played starcraft 2 with no problems before , but i now reinstalled everything and i have this problem now

Processor: AMD Athlon(tm) X2 240 Processor 2.81GHz
RAM: 4,00 GB
System type : 64-bit Operating system

i tried this up like u guys said but nothing changes,,and when i tried to update it says The best driver software for your device is already installed and This device is working properly

Report •

Ask Question