Sims 2 discs not reading

Compaq / Gn582aa-aba sr5250nx
January 4, 2009 at 14:31:30
Specs: Microsoft Windows Vista Home Premium, 1.6 GHz / 1526 MB
I have been able to install the sims 2 base program it took me about three days to figure out the original problem now I have the same problem with the Expansion packs and have tried everything that I did with the base to get it to run. Here's the problem:

When I insert the disc It will read and acknowledge the existence of the disc in the drive but the autorun will not load to install the games. So I will go into the disc contents and try to run the autorun from there and same thing the computer will start to read the disc then stop... no error messages or any thing to saythst it's stopped doing anything just that the "thinking" cursor will dissapeat and be replaced by the standard pointer. I have tried to run as admin also same result, cleaned the registery and such but nothing...

I an running on vista.

any ideas?

See More: Sims 2 discs not reading

Report •

January 20, 2009 at 22:29:04
Hi NeoMalfoy, I love the Sims. I had a simular situation with my computer too. When I had first got my pc, it ran the sims2 smoothly. But I noticed that, "slowly but surly" the more I ran or upload my game, the slower it uploaded. And it got to a point where I couldn't upload my game. So I called HP and we went through a series of tests. Apperantly, I needed a new hard drive. They took very good care of me and they sent a new hard drive. I was able to play the game smoothly. You need see if it is the game or your hard drive. Whatever manufactuer your pc is under, it is always best to talk them, it can turn out to be a serious problem(you know that) ;) .

Report •
Related Solutions

Ask Question