Click here for important information about

SETUP.exe not launching for SWTOR

January 4, 2012 at 12:29:18
Specs: Windows 7, C2D8400; 2GB RAM
so i bought Star Wars The Old Republic at target and tried to install on my Windows 7 64-bit PC. Windows UAC pops up and i click OK, then nothing. so then i go to the website and download the client installer. it downloads, extracts, then tries to run setup.exe and ... nothing.

i've tried rebooting and disabling my AVAST antivirus, but get the same results. Given that i tried from the physical media AND from a downloaded exe, and both had the same issue, i'm a little stumped. btw other exe installers still work just fine.

any thoughts?

Windows 7 64-bit
i7 2600k CPU
256GB SSD with 45GB free

See More: SETUP.exe not launching for SWTOR

January 5, 2012 at 07:21:04
u can try something copy all files on the disk to a hard disk then to ur computer and try it from there...
if it did not work return the disk and ask for another

computers are a second home

Report •
Related Solutions

Ask Question