Sapphire HD 5750 showing poor performance

March 29, 2011 at 10:07:25
Specs: Windows 7
HI people i am using saphire ati 5750 amd altholon dual core 5400+ 2 gb ram 1 tb hdd and 450w psu.I bought my 5750 new but it is quite disturbing me i ran gta san andreas at all graphics set to maximum then it is showing 25 fps.i ran cod 5 sometimes there are 80 fps sometimer there are 20-30 please help i think it should run there game at 60 fps.

See More: Sapphire HD 5750 showing poor performance

Report •

#1
March 29, 2011 at 13:38:07
2GB isn't a lot of RAM these days, especially for Win7. Have you installed the latest device drivers? ATI Cataylst drivers? Do you have a lot of garbage programs running in the background?

Report •

#2
March 29, 2011 at 19:23:22
I think you are right i am using windows 7 64 bit.But my pc slows down after i bought my new Gpu.I think it is sharing my RAM if it is doing so how to remove it.here is an screenshot of my ram usage i am not running any game at this time

http://img197.imageshack.us/i/captu...


Report •

#3
March 29, 2011 at 23:16:17
now that is more than normal memory use.a 64-bit opreating system is used for systems with 4gb+ ram not 2 gb so if you want good performance install a 32-bit opreating system and you will get really good frame rates like over a 130 fps and your computer will be lightning fast.

Report •

Related Solutions

#4
March 30, 2011 at 05:02:02
Thanks for reply will install win 7 32 bit and then i will see fps.Again thanks for reply to both.

Report •

#5
March 30, 2011 at 06:18:38
Go back to Windows XP.

Report •

#6
March 30, 2011 at 08:36:55
i believe ur problem is from the OS its a 64-bit on a 2GB ram. 64-bit requieres 64-bit capable hardware and more resources than a 32-bit does.
or u revert to xp or install win 7 32-bit

computers are a second home
NVIDIA GeForce
toxict51


Report •

#7
March 30, 2011 at 19:45:41
Don't go back to XP.
In fact, you shouldn't have to downgrade to the 32-bit version of Win7. I've seen x64 run on 2GB systems; memory usage is only a tad higher. GTA SA doesn't need much of a computer to run well. I used to play it on a 1.8GHz P3 at 1080p just fine.

What anti-virus software are you using? I've seen some of the Norton and McAfee stuff bring midrange computers to their knees.

Super PIII | Unlocked ES Tualatin @ 1.8GHz (150x12, 1.65v, 512K L2)
2GB PC2700 | 500GB | Radeon x1950Pro | Apollo Pro 266T | Win 7 Pro


Report •

#8
March 30, 2011 at 21:21:03
not just gta sa i am also talking about other games like cod 5.Will use win 7 32 bit.

Report •

#9
March 31, 2011 at 08:18:59
nothing solves buddy i installed win 7 32 bit gta 4 showing 15-20 fps on high

Report •

#10
March 31, 2011 at 13:06:27
Told you that downgrading to 32-bit wouldn't help.

However, you first mentioned GTA SA. If you're playing GTA 4, your processor is slowing you down. GTA4 is a game that likes quad-core CPUs, or dual-core processors with hyper-threading.

Which anti-virus software are you using?

Super PIII | Unlocked ES Tualatin @ 1.8GHz (150x12, 1.65v, 512K L2)
2GB PC2700 | 500GB | Radeon x1950Pro | Apollo Pro 266T | Win 7 Pro


Report •

#11
March 31, 2011 at 21:36:28
I was using avg free latest but now after new windows install i am using no antivirus.i have runned gta 4 on new windows.

Report •

#12
April 2, 2011 at 02:09:43
Get more ram 4gb+
I have a
Processor Intel(r) core(TM)2 CPU 6300 @ 1,86GHz 1.86GHz
Ram 4GB
64bit operating system win7
and ATI radeon 4670 1GB Vram
i run GTA 4 at 35-50Fps at a time :P
Maybe im just lucky lol =D

Report •

Ask Question