PCIE x16 3.0 slot inoperable

May 7, 2013 at 14:48:34
Specs: Windows 7, I5 3570/Geil Evo Veloce 1600/16gb
Home built system, I5 3570k, XFX 7850 3.0 GPU, 750 W Corsair PSU, Gigabyte Z77-DS3H rev 1.1 mobo, Beta Uefi Bios F10f, Zalman ATX mid tower case, 16gb Geil Evo Veloce 1600 memory-2x8gb sticks, Zalman cnps 9900 max-R cpu cooler. Bench tested all parts before full install, used a MSI Twin Frozr 560 ti oc II 2.0 in the PCIEx16 3.0 slot for the initial test as I hadn't received the current XFX 7850 1gb 3.0 GPU yet. It fired up fine for the two days I used it, GPUZ saw it as PCIE x16 2.0 @ x16 2.0 under render test. Once I put the system together in the case and the 7850 arrived I had to do a manual uninstall of the 560s drivers as they didn't want to just go away when deleted from Device Manager. This is when the fun began, I had no trouble downloading the OS which is Windows 7 Ultimate btw but when I tried to install the drivers for the 7850 I ran into multiple issues, finally I had to put it in the X4 slot to get them installed. From that point on the PCIE x16 3.0 slot has been dead. Ive tried 3 different GPUs in it, all from different manufacturers and all 3 are 2.0 versions as the only 3.0 one I have is the 7850. None of them would give me any sign of life, ive went into the Uefi and changed it to PEG repeatedly only to have it default to Auto every single time. Ive changed the display to Legacy as instructed by Gigabyte but to no avail. Ive taken the cpu out and tested it n a friends Z77 chipset system and it worked fine with his Nvidia 3.0 GPU, I installed my 7850 3.0 in his system and it worked fine also. I through a multimeter on the PSU lanes and everything is as it should be, which it being a 750w psu running only one card it is 'more' than enough juice. I am an electrician by trade so that end of it I am quite clear on. I removed the motherboard and all unneeded periphials off the mobo and ran it outside of the case just in the slight chance there was a short to ground somewhere. I got the same result from the PCIE X16 3.0 slot. Ive spent countless hours on every forum and diagnostics site trying to learn more about such an issue but have came up empty. Ive been in contact with 3 different Gigabyte techs via email and on the phone, the latest suggestion was for me to change the PCI ROM to PNP(Plug and Play) which before the Bios's where Uefi I could find and do so, but with the new Uefi Bios system I cant locate anything that allows me to enable PNP on the PCI ROM? Can I access it through the registry? Can I somehow switch the Bios back to analog and find it then? I even found a site called Uefi.org that has some info that might translate on how to do this but so far I haven't figured it out. The section on PCI Roms is tagged as 13.4.2. So yes, any and all suggestions on how to change the PCI Rom to PNP and or another possible fix will and is greatly appreciated.

See More: PCIE x16 3.0 slot inoperable

May 8, 2013 at 08:27:50
Is this a continuation of your other post? Please stick to one thread. And it would help to actually put your specs in list form:

power supply

Also separating your paragraphs will make your post easier to read rather than jamming everything together into one huge lump.

Report •

May 8, 2013 at 09:42:47
Ok, will do next time. But in the meantime what i truly need to know is how to access the PCI ROM in a Z77 chipset system so i can configure the PNP. If someone can give me that info id be set. In the Uefi Bios of my Gigabyte Motherboard the only options you have are either EFI or Legacy, nothing with PNP. Im a noob on the Uefi Bios. Plz help. Thnx.

Report •
Related Solutions

Ask Question