Intel / Dg45id
June 26, 2010 at 04:34:30
Specs: Windows 7
Whenever I tried to install a Car racing game on my Windows 7 desktop pc (Intel Quad core) "Need for Speed Hot persuit 2", a black (DOS) window popups and followed by an error message:
The NTVDM CPU has encountered an illegal instruction.
CS:393a IP:393a OP:ff ff ff ff ff Choose 'Close' to terminate the application."
The same problem is displayed on my another desktop pc having Windows XP sp2 installed.
How to get the problem resolved.
Any help would be highly appreciated.

See More: NTVDM Error

Report •

June 26, 2010 at 07:34:03
You're attempting to play an old DOS based game in XP.

Troubleshooting MS-DOS-based programs in Windows XP

Report •

July 2, 2010 at 23:14:06
This does not seems the problem related with XP, as the same problem is available on my Windows 7 os also. I think this is something related with hardware settings/configurations. In fact, I am facing same problem {"The NTVDM CPU has encountered an illegal instruction.
CS:056d IP:0100 OP:ff ff ff ff ff Choose 'Close' to terminate the application."} on one pc having both os xp &7 installed and another one having only Windows 7 installed.
Any help please.Thanks.

Report •

July 6, 2010 at 10:42:49
Need for Speed: Hot Pursuit 2 is not a DOS game. It was released in 2002.

What video card do you have, and what driver version are you using?

But it looks like this game might not be compatible at all with Win7. Although that doesn't explain why it would also crash on XP.


Report •

Related Solutions

July 7, 2010 at 09:23:40
Have you tried running the game in windows 9x mode under XP?

PowerMac 9600(1 ghz G4)
512mb RAM
50gb SCSI
ATi 9200 PCI

Report •

January 8, 2011 at 04:27:03
I have an old program that has always run fine in WinXP, got a new machine with XP and tried to run the program and got the NTVDM error. All other old (dos and windows) programs run fine. The motherboard in the new machine is nVidia 6150SE nforce 430, using onboard graphics. I tried all the software fixes suggested all over the web but nothing worked. I finally installed a PCI graphics card, changed the cmos to see the card and the program runs perfectly. I have no idea why that would have worked but it did.

Report •

Ask Question