no signal the sims 3

June 6, 2009 at 07:44:46
Specs: Microsoft Windows XP Professional, 1.795 GHz / 1534 MB
Manufacturer: Oem
Model: Oem
OS: Microsoft Windows XP Professional
CPU/Ram: 1.795 GHz / 1534 MB
Video Card: NVIDIA GeForce 6800 Series GPU
Sound Card: Realtek High Definition Audio

all my info above, o im no good with computers but i got the sims 3 today and after about 5 mins of playing on it it just says no signal and my monitor turns off and no matter what i do i cant get it back on, i use to always play sims 2 and it worked fine, any help???


See More: no signal the sims 3

Report •


#1
June 6, 2009 at 07:46:27
oh could it be mygraphics card driver is not up to date or anything like that?

Report •

#2
June 6, 2009 at 08:33:52
If you haven't updated the driver in a while it certainly wouldn't hurt to do so.

http://www.nvidia.com/object/winxp_...

And check your video card to make sure the fan is working & that it's not all clogged with dust.


Report •

#3
June 6, 2009 at 10:44:14
ok thanks for that

Report •

Related Solutions

#4
June 6, 2009 at 13:12:33
yes i bought the sims 3 but mine kept crashing during gameplay after about 10 mins. I always played sims 2 and expansion packs, but the sims 3 is such a high power game. It's something to do with A your graphic card, B memory. You need a lot of Memory GB is bigger than MB so it's worth updating any of the system requirments. Check on the web site to see if your pc can run it. But am going to update by buying a new pc they do some great deals at pc world for pc's with great memory and power for this amazing game. good luck!

Report •

#5
June 8, 2009 at 10:19:12
Ok well i updated my video card driver and sims worked great but then i turned my pc back on and it kept just shutting down so i reinstalled windows as thats my solution for everything lol and it worked ok for about an hour then it turned off again and when i turned it back on it kept going to the safe mode, start windows normally blah blah screen and whatever i selected it turned off and restarted to the same screen, so i decided to clean my fans which are filthy and after a few tries of starting to reinstall windows again it just turns off and wont come back on :( havent even had a real chance to play my new game please help someone do i need a new power supply?

Report •

#6
June 12, 2009 at 09:23:01
Did you clean your CPU fan? Most computer's have a default shut down temperature of 70-90C, and if it's reaching that then it will simply shut off.

It could also be a problem with your PSU, yes, or a problem with your RAM, or a problem with your HDD, or a problem with your motherboard. We need a tad more info before we can really help you.

--Graphics card specialist--


Report •


Ask Question