low FPS WoW

June 26, 2009 at 17:52:43
Specs: Windows Vista
There were similar posts concerning this topic - low fps in WoW. I bought this COmpaq SR5710y about 6 months ago - major upgrade from my older PC. Now I realize its not top end, but everything worked just beautifully till about 3 months ago. I checked your chart of Vid Cards and didnt even see mine listed (NVIDIA GeGorce 9500GT). I log onto WoW, get about a minute of 20-30 fps, then fight through 2-5fps for what seems like forever. When I first brought this computer onoline with WoW I was seeing unbelievable 60fps'. I've started to notice that this is affecting other apps as well - basically slow computer performance. I watch my meter it never seems to go above 60% CPU, even right now with WoW open and the internet my CPU is at 35%. I tried removing any startup programs I could, ran disk clean and defrag - still no luck. I run Comcast cable for internet.

See More: low FPS WoW

Report •


#1
June 27, 2009 at 07:41:00
Try setting WoW's graphic settings to the lowest you can. Try that.
My laptop has 1024 RAM. & the graphics card is a basic ATI graphics card. My laptop runs WoW perfect on the lowest settings. So if you have a NVIDIA Geforce 9500GT It should work perfect in any setting but still put it on lowest to see if there's any difference.

***************************
Need BatchFile Help ?
Msg me :)
***************************


Report •

#2
June 29, 2009 at 17:07:33
I tried that and it worked a little. I was just trying to figure out why it happened all of a sudden. I had heard rumors that there was some new vid code or something in the last big patch, but I dont hear anyone else complaining about it on my server, so i assumed it had to be something strictly with my computer. Is the problem video related, VISTA related, or something else?

Report •

#3
July 5, 2009 at 14:37:09
its just having them work on the new patches

Report •

Related Solutions


Ask Question