I have an old game that no longer seems to want to install

May 1, 2012 at 15:47:55
Specs: Windows 7
Hi there, my brother recently found me a copy of Settlers 3 from back when we were kids. In a moment of nostalgia i went to install it to find an error message waiting for me.

"Setup is unable to find installation languages in C:\SysWOW64\InstallShield\SETUP.LID file
Error 105"

From the sound of it it looks like the problem is with the actual Install itself but im not very good with computers. I have already tried using the in game installer in compatability mode but that hasnt worked either, neither did downloading registry easy cleanup program.
Does anyone have any ideas? Obviously its not the end of the world if not but i know it was quite expensive for my brother and i would like it to work.

Regards in advance

See More: I have an old game that no longer seems to want to install

Report •

May 2, 2012 at 05:19:04
Looks like it's an old DOS based game from the late 90's. It may not be compatible with Win7. Try using DOSBOX.



Report •
Related Solutions

Ask Question