High ping at BF2 servers

Intel / D865gbf
February 27, 2009 at 19:44:08
Specs: Microsoft Windows XP Professional, 2.394 GHz / 2046 MB
My internet ping is 32ms, When I connect to a BF2 server my ping starts out (most of the time) in the 40's. In a very short time it will go up to 900ms. The results is Punk Puster kicks me. I'm running straight through a cable modem, all back round programs have been shut down. All programs have been updated. I have reinstalled the game and related programs several times. I have also researched this site and others for an answer to my problem. The last thing I tried before typing this post was monitor my internet ping while trying to play BF2. I got kicked 3 times and lost connection 4 times. This all happened within a 15 minute period. My ping on the BF2 server when I got kicked was 859ms. I used PingPlotter to keep track of my internet ping and during the time I played BF2, the internet ping never went above 35ms and no packet loss. I was sending 25 packets every 2.5 sconds. I noted the pings that other players had on the server and they averaged around 50 to 60ms, some went as high as 158ms. The same thing happens when I don't run PingPlotter. Can anyone tell me why this is happening when I connect to game server?

See More: High ping at BF2 servers

Report •


#1
February 28, 2009 at 01:53:25
Did you try updating your Punkbuster! Go to google and type in punkbuster client. You should find it preety easily. Download it and go threw the setup. It will ask you to choose a game from a list of Punkbuster supported games. Select BF2 and click update!!! It should fix the kicking and high pings. If not ????? Maybe try a
static i.p. address. If you need help on enabling a static ip send me a private message and i'll walk ya threw it.

Report •

#2
February 28, 2009 at 05:26:55
I have updated all programs related to BF2 and online gaming. All other programs like Windows and hardware were also updated. Punkbuster was one of priority updates I made. I have redownloaded it a couple of times thinking I got a bad download. I have gone though many tweaks that were suggested by other players. I believe my machine is running very well. I just can't explain the wierdness in the ping when connected to a BF2 server.

Report •

#3
February 28, 2009 at 12:24:01
sorry man have no Idea. send a privet message to "jam" he is a member here and He has helped be threw think and thin. So hit him up!

Report •

Related Solutions

#4
March 4, 2009 at 20:38:19
Although I have a cable modem with a bandwidth of 1.5Mbps, I have been setting BF2 settings for the DSL or Modem better than 256kbs setting. I had run out of options trying to solve my problems so I set my connection speed in BF2 to T1. I tied it and guess what...My ping to the servers dropped to almost normal, about 45ms. I still get disconnected once in a great while, but I think thats normal for some servers. I'm back to playing again. I hope this helps some of the people that have the same problem that reads this post.

Report •

#5
March 4, 2009 at 23:06:19
cool man good to hear so you set it to T1 im gonna try right now

Report •


Ask Question