games suddenly lagging on new laptop

October 15, 2010 at 15:31:58
Specs: Windows 7
All games suddenly lagging on new laptop

I bought a new laptop few weeks ago, every game I tried was running smoothly at least on medium. But recently every single one, even old ones lag and stutter. I tried lowering settings (that helped not by much), tried updating drivers, used system restore point from day one (that solved the problem, but just for one hour), scanned my PC and fragmented hard drives (2), but nothing helped (not for long). I am using notebook cooler so overheating cant be the cause.

Weird thing with Battlefield Bad Company 2. that was the 1st thing I tried. It lags on SP now, units are really jumpy when they move and it is hard to aim, BUT on MP I have high ping (180 - 300) but units don't lag. In fact MP is just as smooth as in day one.

Then I noticed that frame rate doesn't drop in other games either, but units or cam is really jumpy. For example, in Napoleon Total War campaign map cam is lagging, but units, flags, rivers etc. don't. (on battle map both units and cam lag).

In all games I've tried it is not traditional lag, more like skipping, jumpy animation.

My specs:
Emachines E730G
Intel Core i3 (2.27)
ATI Mobility Radeon HD 5470
3 GB DDR3

Win7

Sorry for my English!
thanks for help.


See More: games suddenly lagging on new laptop

Report •


#1
October 16, 2010 at 02:55:35
try using a graphc card just in case u dont have one...
and if you have one, thn try configuring it, Maybe it will help..

http://www.cellhub.com/t-mobile-cel...


Report •

#2
October 16, 2010 at 03:15:40
Try using a graphic card? what do you mean? Messing with graphic card driver? I've already done that.

Report •

#3
October 16, 2010 at 04:23:57
@ both of u
labtops dont have graphics cards they have what we call igp its graphics chip is integrated to the motherboard
anyways check ur labtop temperatures ur motherboard temperature mostly

computers are a second home
NVIDIA GeForce
toxict51


Report •

Related Solutions

#4
October 16, 2010 at 05:40:23
CPU temperature is about 42, but it raised up to 56 when I launched a game (Battlefield BC2) It was on just for a few minutes.
I was using Piriform Speccy to monitor the temperature.

Report •

#5
October 16, 2010 at 08:58:27
did u download ur latest graphics driver ?
cpu temps are normal
plus wut setting(resolution etc) ur using on ur games the HD 5470 is not that much of a gamers graphics chip
computers are a second home
NVIDIA GeForce
toxict51


Report •

#6
October 16, 2010 at 09:14:08
All the new games I play on medium with no problem, that is I used to. And yes I have the latest graphic driver.

Report •

#7
October 16, 2010 at 09:20:59
@toxict51
"labtops dont have graphics cards" yes they have (gaming laptop), hd 5470 is a pci-e v-card.

@Panadox
Try to update v-card driver (uninstall ATi driver then restart the system and install new drivers, u can download new drivers from ATi website) also try to re-install games.


Report •

#8
October 16, 2010 at 11:21:49
Just tried kuwese's suggestion, it didn't help.

Report •

#9
October 16, 2010 at 11:34:28
Try to install ATi drivers withou ATi catalyst.

Report •

#10
October 17, 2010 at 04:12:56
I was reinstalling ATI driver (with catalyst, it didn't allow me to install without it) and when it was done a message showed up:

Warning!
The Catalyst Control Center is not supported by the driver of your
enabled graphics adapter. Please update your ATI graphic driver,
or enable your ATI adapter using the display manager.

I was installing the latest driver that I found at ATI website.
I am kinda new to this, can this be the cause? How to fix it?


Report •

#11
October 17, 2010 at 08:12:02
@kuwese didnt know that
but how can a pci-e card fit in a labtop ?
isnt it a mobility card in a gaming labtop as far as i know HD 5470 is a pci-e card but HD 5470 mobility is a graphics chip in a gaming labtop correct me if im wrong i would like to know if im wrong
computers are a second home
NVIDIA GeForce
toxict51


Report •

#12
October 17, 2010 at 08:57:47
My PC doesn't recognize my ATI card, on devise manager it just says Standard VGA Graphics adapter. Why? I am using the correct driver. And it worked fine before. Any one know what could be wrong? I will try to install driver that came with the laptop on disc and see how it works out.

Just tried that. Uninstalled CCC installed separated version of it and it finally recognised ATI graphic card. I reinstalled the game, installed the latest Direx but it had no effect on performance. Still jumpy. I have no idea what to do next.


Report •

#13
October 17, 2010 at 14:47:09
Well, I fixed the problem, have no idea how, but here's what I did - uninstalled graphic drivers, installed just CCC (outdated) then installed ATI mobility driver (found on ATI website) restarted my laptop and everything was fine. Seems that CCC was messing the whole thing, don't knew why, but the one that I used before didn't want to cooperate with my graphic card.

Thanks for support!


Report •

#14
October 18, 2010 at 10:37:56
Nope, problem returned. I didnt fix it I just made it more bearable. So far I have tried battlefield BC2, but here what is happening - when I start SP, it lags, but when I start MP, that doesn't lag, and then start SP, it doesn't lag anymore. After restart it lags again. Seriously, what the hell is going on!?

Report •


Ask Question