Game won't open

Ubisoft Assassins creed
July 14, 2010 at 07:45:40
Specs: Windows Vista
Hi, for a while I've had this problem with many
games in fact. I installed the game and at first,
it opened fine. Now, when I try and open it, it
won't even bring up a launcher. Nothing
happens when I try to open it. I tried to open it
from the game file, I tried to open as
Administrator - nothing. However, if I go to task
manager, the game shows up in the
Processes list. Therefore the computer
recognizes it as running, although the program
didn't even start up.

It's strange, it only happens with games. All
the other programs open fine. I reinstalled the
game several times, no change was made.
When I try and open the game, nothing

Do you guys know how to fix this? Thanks!

I have Windows Vista, Intel Pentium dual-core CPU
64-bit OS
600 GB hard drive

See More: Game wont open

Report •

July 14, 2010 at 13:50:01
Most important spec when dealing with gaming...whats your video card?

Intel P4 640 w/HT 3.20GHz
Nvidia GeForce 9600GT 256-bit, 512MB GDDR3
23" LG Flatron

Report •
Related Solutions

Ask Question