Solved Game fails to start for seemingly no reason

July 3, 2013 at 17:29:51
Specs: Windows 7, intel core i7 2620M / 8Gb
I purchased the game Deus Ex: Human Revolution through Steam recently, and It always fails to start. Steam will show the little startup message, but after that nothing happens. If I try to start it again I will recieve a message reading "Failed to start; app already running". I tried resetting my computer, i even tried reinstalling. I contacted Steam Support about this issue, but have yet to get a reply.
My laptop is a Dell XPS L702X.

See More: Game fails to start for seemingly no reason

Report •


#1
July 4, 2013 at 05:30:22
✔ Best Answer
Hi BERTthePenguin,

Please right click on the icon and run it as an administrator.

If the issue persists, uninstall the game completely using Revo Uninstaller. Click the link mentioned below for Revo Uninstaller:

http://www.revouninstaller.com/

Perform a deep scan to remove the game from the registry as well. Restart the system and update direct x and the Video driver using the link mentioned below:

DirectX : http://support.microsoft.com/kb/179113

Video Driver : http://dell.to/10Br0ag

Please select the correct operating system and the video card.

Restart the system and install the game.

Thanks & Regards
Manshu S
#iworkfordell


Report •
Related Solutions


Ask Question