Click here for important information about

e drive not reading disc

Take 2 interactive Sid meiers civilizati...
December 14, 2010 at 00:19:24
Specs: Windows Vista, lots more than I could ever use
I bought Civilization V my E drive would not read it, my partners computer did read it. My E drive still works. I have a USA PC. I live in NZ. My partner's PC was bought here. I exceed the minimum requirements for the game. I ran the game demo and it worked out fine. So what's the mystery?

See More: e drive not reading disc

December 14, 2010 at 05:19:37
My guess is u are trying to read DVDdisc into CD drive. When u insert the disc whap happens? Did u try to open my computer and double click drive E? list the system specs.

We can not fight new wars with old weapons, let he who desires piece prepare for war - PROPHET.

Report •

December 14, 2010 at 21:45:45
I can read either cd or dvd, the E drive shows no disk . when I click on the e drive it pops open the door and says to insert disk. I know the disk is ok as it reads in another computer, and I know my rewader is ok as it reads other similar types of disks, weird, eh?

Report •

December 16, 2010 at 01:16:09
some times happends with dvds uninstall your dvd drive in device manager and restart your pc (your dvd drive will be automaitcly reinstalled)then it should work

it worked for me

Report •

Related Solutions

December 16, 2010 at 23:11:57
MY computer reads both dvd and cd. I ran it in my partners computer, got to the point where it said play game , looked like it started then it crashed. It might be something to do with my security. This game comes through steam, my system might be interacting, not sure. This is the only time my computer couldn't read a disk.

Is it possable that disks purchased in the NZ?Aus market are somehow protedted by some mechanism in an effort to prevent priracy? I bought this from a store.

Report •

Ask Question