Solved Direct3D IS enabled, but no Direct3D accelerator found?

August 12, 2013 at 09:37:29
Specs: Windows 8, intel i3 2.2GHz/ 4GB
I have installed a game that requires Direct3D to run. It needed d3drm.dll to run, so I got that installed. My computer has Direct3D acceleration enabled, but when I try to run the game, it says no DirectX 3D accelerator found. what do I do?

See More: Direct3D IS enabled, but no Direct3D accelerator found?

Report •

August 12, 2013 at 09:59:51
You may need to put the D3DRM.DLL file in the games directory (if the game requires it), but that depends.

Normally you would just need to install the DX runtime, check DXDIAG and be good to go.

latest DirectX runtime:

Can you supply the game title and make/model of your workstation for additional details?

Report •

August 12, 2013 at 10:36:33
Game Title is Lego Rock Raiders, make/model is A Sony Vaio VPCEA22FX. It was originally installed with windows 7 but I did a fresh install of Windows 8. Also, I DID place the D3DRM.DLL File into the game's directory. One last thing, I tried to do the latest DirectX runtime using the link you posted, but it tells me I have a later or equivalent version already. I know this game doesn't normally run on Windows 8, but I have absolutely no idea how to create a virtual xp so that I can play it

Report •

August 12, 2013 at 10:47:30
✔ Best Answer
- Install Directx 6 (Old, but has some dll's RR uses)
- Set compatibility mode to Windows XP SP3.
- Enable 'Reduce colour mode' and set that to 16bit.
- Run the game from the executable (not shortcut) and select 'Windowed' mode.

message edited by jpag3074

Report •

Related Solutions

August 12, 2013 at 11:34:00

Report •

Ask Question