Certain games not starting

Dell / LATITUDE D610
April 17, 2009 at 08:44:35
Specs: Windows XP, 504mb
Hey ya'll, I have a Sony CDRW/DVD crx830e cd-rom. My computer is a refurbed Dell Latitude D610
It has an Intel Pentium M Processor (1.86Ghz) and 504mb of ram.

I installed an old favorite game of mine called Age of Empires: The Conquerers Expansion. Well I get it installed and when I click play, my Kaspersky anti-virus comes up and tells me that the file is an Invader - okay, that happens alot. So I put it on the trusted list and continue on, but instead of loading the game, it sits at the loading screen for half a second, then does nothing. The game does not start, and the process for the game is not listed anymore in Task Manager. It just stops. I turned off Kaspersky and tried again, and the same thing happened.

I thought maybe my disk was just messed up, cause it does have quite a few scratches. So I installed another game, Sim City 3000 Unlimited. Again, I get it installed and click play, but this time it just goes in a loop - when you click play, it will go to the "Maxis" logo (which is the loading screen for that game) and will take you right back to the menu for the disk.

I've also tried un-installing and re-installing these programs, but nothing seems to work. I thought maybe it was a driver issue with my CD-ROM, so I tried to find some more up-to-date drivers myself, but was unsuccessful. I also saw a suggestion for using Registry Editor to fix the problem, but the files they indicated that you needed to edit weren't even in my registry.

I have posted a topic very similar to this in another forum and was told that because I didnt have a whole lot of ram, i couldn't play the game. Well, I can play World of Warcraft, Ultima Online, and Warcraft 3 Frozen Throne just fine on this machine with no problems whatsoever, so I don't think the RAM or the processor is the issue.

Someone help me. ;_;

See More: Certain games not starting

Report •

April 17, 2009 at 10:46:05

Report •

April 20, 2009 at 06:22:40
Sim City 3000 Unlimited system requirements are:

SimCity 3000 Unlimited: CPU Pentium 233 MHz or K6, 32 MB RAM, 2 MB DirectX 7.0a-compatible video card, 450 MB hard disk space

You don't have enough RAM to play this game. You might go to a computer repair shop and see about getting compatible RAM for your system to increase this. www.crucial.com will tell you compatible RAM types for your motherboard, but from what I can see, at least with this game, you don't have enough RAM to run the game.

Report •

Related Solutions

Ask Question