Can't Load C&C 3 series

February 8, 2012 at 17:51:04
Specs: Xp, P4 3.0ghz HT/2.0gb
Hi, guys, need some help on this matter......

I helped my friend installed c&c 3 (tiberium war, kane's wrath as well as red alert 3) on his pc and when tried to load, the game hang on the splash screen. It happened on all c&c 3 series and red alert 3 series. I had tried patching all new patches but in vain. Please help.....

My friend's rig :
Intel P4 1.80ghz
1gb ddr1 ram
asrock M266A motherboard
cooler master extreme power plus 390W
Nvidia geforce FX5500
80gb wd harddisk
Win XP SP3

See More: Cant Load C&C 3 series

February 8, 2012 at 21:26:00

Googling is quicker than waiting for an answer....

Report •

February 8, 2012 at 22:21:14
I'd checked the requirements but I did remember that I can run this game using the same spec as above except that it was msi motherboard. I suspect that it may be due to asrock board drained too much power as there is no +12v (4pin) rail socket on
the board itself. Any suggestions?

Report •
Related Solutions

Ask Question