Solved Black Mirror 3 used to work, now cannot start directX. Why?

May 30, 2015 at 10:48:38
Specs: Windows 7, Intel Core2 6400 @ 2.13 GHz
Black Mirror 3 worked on my system until I bought a better monitor, at which point it started giving me the directX error instead. My graphics card is an NVidia GeForce 9400 GT running directX 11, and as stated, the program was working before. The only change (aside from Windows updates) was the recent installation of a WQHD monitor (2560x1440 resolution). The error is "Could not initialize DirectX adapter."

message edited by Yaba

See More: Black Mirror 3 used to work, now cannot start directX. Why?

Report •

May 30, 2015 at 11:03:52
The 9400 GT is an older (2008) low end card & does not support DX11. You're expecting a lot out of it to run a 2560x1440 display.

You didn't state which version of Win7 you're running, but try installing the latest Nvidia graphics drivers.

32-bit drivers >>

64-bit drivers >>

message edited by riider

Report •

May 31, 2015 at 03:41:15
✔ Best Answer
Thank you for the suggestion, riider. That did not solve the issue, but I appreciate the effort.

After installing the latest drivers, and wasting a few hours on a disastrous attempt to replace DirectX 11 with an earlier version, I eventually did find the source of the problem. Before my current display, I was using two monitors a 1024x1280 (portrait rotation). Black Mirror 3 ran on one monitor at 1024x768 resolution. When I switched to the new single monitor, the program tried to force the screen resolution to the one it remembered (1024x1280 portrait), which the new monitor does not support.

To solve the problem, I used an open-source application that allows other full-screen-only applications to run in a window. When I ran Black Mirror 3 from inside the window control utility, the window automatically resized to its remembered resolution. Once I modified the window configuration to match the one forced by the program, I was able to adjust the resolution to a compatible setting. It now runs normally, without errors, at 1920x1080.

For anyone else experiencing DirectX problems, download the application from here (no install needed):

message edited by Yaba

Report •

May 31, 2015 at 18:42:50
Interesting fix. Glad you got it sorted out, & thanks for reporting back on how you did it.

Report •
Related Solutions

Ask Question