All of my games lag even if i watch an video

Valve Team fortress 2
December 31, 2009 at 06:42:18
Specs: Windows XP
all games even youtube videos lag and i have a new graphics card and it still lags and it lagged on the old graphics card too. It runs fine for 5 min then lags for 1 min then just continuing like that

PLZZZZ SUBSCRIBE AND HELP ME!


See More: All of my games lag even if i watch an video

Report •

#1
December 31, 2009 at 06:54:31
don don panic wuts ur new graphics card u bought

Report •

#2
December 31, 2009 at 06:57:52
ATI Radeon HD 4600 series

Report •

#3
December 31, 2009 at 07:34:17
The lag started when i was playing and the elektricity went away and i left it in so they would fix it and i got it back and then it was lag on every game and video even on youtube


It has been like that for about 6 months and i really wanna fix it cant stand it anymore


Report •

Related Solutions

#4
December 31, 2009 at 07:53:02
*4600* series 4600 wut 4670, 4650 etc anyways it could be that the power surge caused damaged ur card that might be the problem
it may have not damaged ur card but damaged something else too but its the lag then its the card

Report •

#5
December 31, 2009 at 07:58:17
what do you mean i put it in for like 2 weeks ago

Report •

#6
December 31, 2009 at 08:03:48
it was like this on my old graphic card too

Report •

#7
December 31, 2009 at 08:05:32
u should have mentioned this
before but since u did now wut card u have in the 4600 series

Report •

#8
December 31, 2009 at 08:14:35
ATI Radeon HD 4670

Report •

#9
December 31, 2009 at 09:10:16
"The lag started when i was playing and the elektricity went away and i left it in so they would fix it and i got it back and then it was lag on every game and video even on youtube"

Decode that for me.

Are the lagging games all online games?

Skip


Report •

#10
December 31, 2009 at 09:18:35
offline and online

Report •

#11
December 31, 2009 at 09:54:01
List your specs. All we know is which video card you have.

Report •

#12
December 31, 2009 at 10:03:22
2 GIG of ram and one 3.23 processor i dont really know how to see what i have i just know those two

Report •

#13
December 31, 2009 at 10:14:43
Intel(R) Pentium(R) 4 CPU 3.20GHz
2.0 GB Ram
Microsoft Windows XP Home Edition (Build Service Pack 32600)
ATI Radeon Graphics Processor (0x9490
ATI Function Driver for High Definition Audio - ATI AA01
HL-DT-ST DVD-RW GWA-4163B DVD-ROM

Report •

#14
January 1, 2010 at 23:52:55
ok, given the problem it could be that your ram was damaged, or
worst case scenario your cpu and mobo :(. I would not think the
gcard has anything to do with this lag. It could also be
something wrong with the power supply. I can't really tell you for
sure what part is fried without seeing it. If it is not visually
noticable I could not tell you at all. Take it to some sort of pc
repair place, they can run diagnostics and use tools to actually
test if something is physically wrong. We are limited online, and
obviously unable to do that.

-Intel i7 Bloomfield 2.66Ghz Quad Core
-6GB OCZ Gold DDR3
-XFX Radeon 4890 1GB
-150GB Velocirapter Boot
-1TB WD Caviar Black x2 Storage
-650W Corsair 650TX
-Thermaltake Element S


Report •

#15
January 2, 2010 at 04:15:30
if u wanna know if something s fried in ur pc open the case up and there should be a smell near ur cpu or ram sticks
if it is take is to a repair shop

Report •

#16
January 2, 2010 at 04:20:35
its no smell

Report •

#17
January 8, 2010 at 11:55:09
thats weird

Report •

Ask Question