Solved WD 2TB Passpost Ultra not ejecting properly

November 17, 2016 at 14:29:07
Specs: Windows 10
I'm running Windows 10 also 2TB WD Passport Ultra, past 3 days WD will not eject properly! Could there be possible damage to my PC? I have read of many individuals having their WD Passport being destroyed!!!

message edited by BLMaus


See More: WD 2TB Passpost Ultra not ejecting properly

Reply ↓  Report •


#1
November 17, 2016 at 14:44:31
Does it eject when used on a different computer?

Always pop back and let us know the outcome - thanks


Reply ↓  Report •

#2
November 18, 2016 at 01:47:44
The problem may be the builit in electtronics board, to which that usb port is attached...

More than one manufacturer has had problems with their cases, invariably the onboard electronic being the problem, and occasionally the actual usb port itself.

I suggest you remove the drive from its housing, and connect it your computer using an adapter cable set.

That way you can safely verify the drive is OK. Presuming it is there are decent cases on Amazon and elsewhere which you can use to rehouse the drive.


Reply ↓  Report •

#3
November 18, 2016 at 12:36:32
✔ Best Answer
trvlr - Thank you so much for your assistance... You read my mind, today when I plugged in I decided to use the USB port above the one I have always used. Everything seems to be working as it should! Once again thank you "all" for your input, words of wisdom and hope I can be of assistance to you. BLMaus

Reply ↓  Report •

Related Solutions

#4
November 18, 2016 at 14:13:18
I was thinking of the port on the usb drive case... as that's often a point of failure. Either mechanical or electronic.

Personally I have never come across a desktop/tower usb port that failed. Quite possibly you may need to re-install the drivers for the port - usually are part of the chipset these days?

When you feel inclined to, have a look in Device Manager and see if there are any yellow exclamation marks in the usb listing at the bottom of installed devices?

But at least you got to a working port in the end...

message edited by trvlr


Reply ↓  Report •

#5
November 18, 2016 at 14:31:36
Good to hear you fixed it and thanks for letting us know.

message edited by Derek


Reply ↓  Report •


Ask Question