USB Ports Not working and Audio device wont work on Windows7

May 22, 2020 at 08:11:13
Specs: Windows 7 Professional Service pack 1, E5200 @ 2.50GHz 2.50GHz 3.00GB Ram
Audio Devise not recognized in windows7:
I have windows 7 professional 32bit.
My audio ports stopped working and if I plug my audio devise or headphones in and colour port it just stopped.So I got a "UGREEN USB 2.0External Stereo Sound Adapter and plugged it in a usb port and into my Audio devise and it played immediately with no need to install any drivers.
But now When I plug it in any usb port its show: "One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it"
When I click on the message I get this:'Windows has stopped this device because it has reported problems. (Code 43)"
When I click on Driver details, I get this message:" No driver files are required or have been loaded for this devise"
When I click on Update driver, I get following message: "The Best driver software for your devise is already installed .Windows has determined The driver software for your devise is up to date"
I went on device manager and In the list of hardware categories, find and expand Universal Serial Bus controllers.I Uninstall every device under the Universal Serial bus controllers to remove one at a time, restarted and waited for Usb controllers to reinstall. When I plug the devise in ,again the message: One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it"
But If I go to playback devise, or troubleshoot, it keep on telling me that peripheral does not appear to be plugged in..And troubleshooter say the speaker,headset or headphone is unplugged.,
I tried recovering to previous restore point, with no success
I tried Disable USB selective suspend setting on power plan and nothing. I updated everything on windows update..I am using Realtek high definition Audio driver, and Realtek Audio driver, and Realtek Semiconductor, etc...
I know easy thing to say windows 7 old and bla bla bla..And go over to windows whatever...
I Dont have money to switch my toothpaste from noname brand bro..Please I need to work with my computer with sound
Regards
Shawnlee

See More: USB Ports Not working and Audio device wont work on Windows7

Reply ↓  Report •

#1
May 22, 2020 at 12:51:10
Windows 10 is still free.

Are you asking about a desktop or laptop? What troubleshooting did you do for the audio port problem? Do you have a video card that may have hijacked the default audio setting? Code 43 generally means a hardware problem.

message edited by riider


Reply ↓  Report •

#2
May 22, 2020 at 14:19:43
No its a old PC. Pentium Dual-Core 32 bit
Asus P5KPL AM SE
If the audio dont work there is like a red icon with a cross on the volume icon on the desktop.If I CLICK on it a message Pop up and say: Playing Audio. Detecting Problems. And then give 2 options which i want to troubleshoot.1)Speakers:High definition Audio, or 2)Realtek HD Audio 2nd output-Realtek High definition Audio.
I can choose anyone and then the answer will come that peripheral does not appear to be plugged in. And follow with the speakers, headset, or headphone is not plugged in.
You say windows 10 is free? If so..Wont it solve my problem?And where and how do I get it?

message edited by Shawnlee


Reply ↓  Report •

#3
May 22, 2020 at 14:47:48
If that's the correct motherboard model, you don't have the right drivers. According to the ASUS specs, the audio is VIA VT1708B 8-Channel High-Definition Audio.
https://www.asus.com/Motherboards/P...

I suggest you uninstall ALL current audio drivers, then download & install the VIA drivers. Here's a direct download link: https://dlcdnets.asus.com/pub/ASUS/...


Reply ↓  Report •

Related Solutions

#4
May 22, 2020 at 15:55:00
Thank you so much riider.I will give you feedback as soon as possible.

Reply ↓  Report •

#5
May 23, 2020 at 23:49:11
Hi riider. I followed your advice and used the download link.So it download the file and install, but at the very end of installation a message show that "No Audio device found".
And everything is still the same. I gave up..Even now when nothing is plugged in at any audio or usb port, still get these pop up messages "One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it" In short, I got nothing fixed and all is the same.Wonder if its better to download Windows 10?


Reply ↓  Report •

#6
May 24, 2020 at 12:25:10
Windows 10 isn't going to help if you have a hardware problem. Check the BIOS settings. Make sure the onboard audio is enabled.

Reply ↓  Report •

Ask Question