Solved Installshield wont install anything

September 18, 2014 at 10:06:13
Specs: Windows 7 Untimate, 8GB
I am trying to update my drivers. My sound drivers for my onboard sound and my add in sound card. On is Creative drivers the other is from Realtek.

When I double click the exe it extracts the files and then nothing. I found the folders with the Setup.exe in them. When I double click the Setup.exe the Installshield window pops up and says preparing files, the bar fills up, then it closes and nothing still.

I have done this in a Clean Boot with my Antivirus completely turned off and it still does not work. I can not figure out why the Setups will not install and why they just close.

Please Help, thank you.


See More: Installshield wont install anything

Report •

#1
September 19, 2014 at 09:20:04
Since they are drivers, it could be a "silent install" since there are no "where to install" options with most drivers so there's no need for any further input from the user.
That's just a guess mind you.

Check the Creative driver to see whether or not they have in fact updated to newer version compared to the version you had previously.

Tip: If you are using an add-on sound card there is no point in updating driver for on-board sound as that will have been disabled in the BIOS settings to avoid a resource conflict. In fact, on-board sound driver will refuse to install anyway for that reason because it won't be able to find hardware that's been disabled.

Finally, if your current sound driver is working okay you shouldn't be updating it anyway, and that applies equally to all drivers.

If it ain't broke, leave it alone.

message edited by phil22


Report •

#2
September 20, 2014 at 20:59:31
Yeah well I should have left it alone (addon drivers) because now its frustrating.

Yes you are right both the addon and onboard drivers installed silently but now the issue is that neither will install the software.

My addon card doesn't have the pins on it for the front audio jacks on the new case I bought. So I am using the onboard for the front jacks and the addon for the speakers. No driver conflicts.

I hadn't noticed at first the drivers were installing silently. I guess the issue is, the software wont install, after the drivers have been fully installed the installation just stops at that. Very odd to me.


Report •

#3
September 21, 2014 at 02:09:26
✔ Best Answer
Thanks for all the help but I TECH SMASHED IT!! lol anyway.... Some how my DEP got set to always on (bcdedit.exe /set {current} nx AlwaysOn). DEP was crashing Installshield.

I ran the command to set it always off (bcdedit.exe /set {current} nx AlwaysOff).

Restart

Then I ran the MSoft fix, make sure to uncheck all but the DEP option(http://support.microsoft.com/mats/windows_security_diagnostic/en-us)

Restart

This re-enabled the greyed out choices in; Start, Computer right click Properties, Advanced system settings, Advanced Tab, Performance Settings, DEP Tab, so that I can choose "Enable for essential programs only".

Restart just for fun

All done!!


Report •

Related Solutions

#4
September 21, 2014 at 23:26:16
Please Mark As Solved

Report •

Ask Question