How to resolve printer is offline when it is not?

Canon Pixma mg6220 all-in-one inkjet pri...
January 1, 2017 at 17:01:33
Specs: Windows 10, hp Pavilion 8 gigs
Have Canon pixma MG6220 printer. Had been working until a few days ago when I received a "printer is offline" message. Had seen this before with the scanner, an issue I never resolved. I re-installed the printer driver and this time both the scanner and printer started working.Two days later, I tried to print something and got the same "printer is offline" message. I don't want to have to reinstall the driver each time I want to print something! The scanner problem (same offline message) started some time after upgrading to Windows 10, but I've been printing successfully for at least 6 months since the upgrade. Printer is connected to PC via usb port.
Diane

See More: How to resolve printer is offline when it is not?

Reply ↓  Report •


#1
January 1, 2017 at 17:30:58
As a starter... Have you checked in the various Canon sites for the latest Win-10 drivers..?

Also, have you checked in device manager to see if there are any yellow exclamation marks next to rhe printer icon or the usb entries?


Reply ↓  Report •

#2
January 2, 2017 at 12:47:24
Does the printer have a low power usage setting? If so, then the computer may just be determining that the printer is off when it is in low power mode.

To turn off the Auto Power feature you will need to find the Maintenance tab. If you install the manual from here:

https://www.usa.canon.com/internet/...

It will guide you through how to turn this feature off. It also looks like you will be able to find it easier on the printer's touch menu. It is located in the "Devices Setting & Maintenance" column.

I don't need to be right, but I am never wrong.


Reply ↓  Report •

#3
January 2, 2017 at 13:54:12
Thanks for your suggestions. I've discovered something that may help solve the problem. First, though, I had installed the latest Windows 10 driver from Canon for my multi-function printer/copier/scanner earlier in the week. I was able to print right after that but not 2 days later. There are no yellow exclamation marks next to the printer icon or any of the usb entries.

This morning I looked at the properties of the printer and discovered a message that said: Currently, this hardware device is not connected to the computer. (Code 45). This is really odd because I stumbled upon something interesting last night while trying to fix this problem and before I saw the Code 45 message.

Last night, I decided to turn the printer off and reboot the PC. When the PC had been rebooted, I found that my Desktop Icons were gone and I had a different desktop display. While trying to find out what I could do to go back to the way it had been before, my search results ended up being shown in Microsoft Edge. I have been using Chrome for years. At some point, I decided to try to print using the Microsoft browser. It worked! Then I went back to Chrome and I got the message that the printer was offline. Today I saw the 2 responses sent to me via this site (trvlr and stiefler182). After looking at the properties of the printer in device manager, as suggested by trvlr, I saw the message saying that the hardware device is not connected to the computer. I then tried to print again, both with Microsoft Edge and with Chrome. Printing works with Microsoft Edge, but not with Chrome. I'm also able to print a Word document. So the problem seems to happen only with Chrome, which I much prefer using. It's strange that the properties in device manager for the printer state that the hardware device is not connected to the computer and I'm able to print - except in Chrome.

So, I don't think the problem has anything to do with a low power usage setting.

Any thoughts given this new information? Thanks.



Reply ↓  Report •

Related Solutions

#4
January 2, 2017 at 15:20:09
Hello again,
I think I have a solution, although not a completely satisfactory one.

I had noticed that there were 2 devices that show up for my Canon MG6220 - One that says Canon MG6220 Printer and another that says Canon MG6220 Printer WS. I had discovered this while trying to figure out why the printer was offline. I'm pretty sure that both of them said they were offline earlier this week. I decided that the WS must have been the one for printing via WiFi. I just learned that this is so from a post on the Canon website.

Just now, when I brought up the Devices page, I saw that the one without the WS was the default, as it should be, and that the one with WS was offline. I looked at the queue and saw that a number of documents that I had been trying to print, but couldn't, were in this WS queue, where they should not have been. A comment on the Canon website where I read about the WS versus non-WS device, said something that made me think to check the destination when the PRINT page comes up. There's a way to change the destination. You can't tell which printer device it's trying to print to because there aren't enough characters to display the entire name, but when I went to change it, the WS printer was on top, so I assume it was the one being chosen. I don't know why because the non-WS printer was the default. Having changed it once, it now seems to want to print to the correct one. This is all on Chrome because printing from Edge or Word was working. Why the Chrome browser software was choosing the wrong printer (just since a few days ago) is a mystery. But at least now I know that the problem stems from there being two printer devices (one virtual?) and that the wrong one was being selected.

Thanks for your help on this. I've spent way too much time trying to figure this out.

Diane


Reply ↓  Report •

#5
January 2, 2017 at 15:27:47
Have you looked in your devices and printers on the PC and picked a primary printer on the computer. If it is a network printer then it will have (Network) beside the title. If there is the problem of 2 printers conflicting with Chrome then uninstall only one of the printers and leave the (Network) printer.

I am not as familiar with Chrome as you would be, but I know Chrome lets you choose default program and devices. Maybe scroll through those setting and correct any anomalies you find.

I don't need to be right, but I am never wrong.


Reply ↓  Report •

#6
January 2, 2017 at 22:55:52
Am I interpreting correctly that you have the printer installed in both wifi and ethernet/cat-5 modes? If so then generally Canon advise enable one or other protocol, style of connection only. Having both enabled may cause connection and thus printing errors...

My elderly (by current standards) Canon mp600r does allow both options enabled, but current models appear not to allow it; one can have or other enabled at any time, not both.


Reply ↓  Report •

Ask Question