Gigaware Optical Mouse Lights Up W/No Response (SOLVED)

June 12, 2015 at 09:29:34
Specs: Windows 8.1, 3.8 Ghz / 16 GB
This was meant to be a follow up to an older thread, but it wouldn't let me post because it was so old. I solved this issue using windows 8.1, I wanted to reply because I didn't find a true solution for this problem anywhere online, but it seemed lots of people were experiencing the same trouble. If you go to Control Panel>Devices & Printers, you should see your optical mouse at the bottom of the box listed as "unspecified". select your mouse and bring up the device information dialogue box, select the hardware tab- then choose "properties", then "change settings". In the dialogue box that opens, go to the "driver" tab and choose "update driver". Choose "browse my computer for driver software" select "USB input device" and your computer will assign the correct drivers and your mouse will begin to work. This worked for my Gigaware optical USB mouse. It didn't respond at all except for lighting up, but it turns out that my computer identified it as an X-Input device for X-Box 360- so basically my computer didn't think my mouse was a mouse. Probably the issue for many of the others who are experiencing an unresponsive Gigaware optical mouse.

message edited by cythetrue


See More: Gigaware Optical Mouse Lights Up W/No Response (SOLVED)

Report •

#1
June 12, 2015 at 09:53:24
Thank you for the info; might well e useful for others too.

Cheers...


Report •
Related Solutions


Ask Question