AMD RX 480 Windows 10 64Bit

April 17, 2019 at 03:31:29
Specs: Windows 10, 8GB
This issue is crazy... This system was on AMD Crimson 17 and when I updated to 18 and all this crap started. I recently updated to Crimson 19 and nothing has changed/fixed. On Crimson 17 everything worked fine, AMD Control Panel and such. Going back to 17 did not fix the issue.

I uninstalled the AMD Software (Crimson 17) through the control panel and it asked me to restart, nothing out of the ordinary... When the computer restarted before I could even start the new Install windows installed a Really old version of the Catalyst drivers... I went back to the Control panel and uninstalled these drivers. I went into the windows Update Cache and wiped it. I double checked that windows was not able to install drivers on its own and "NO" was chosen.

I restarted the computer and it installed the Catalyst drivers again... I went through ALL the previous steps and then disabled the network adapter and rebooted. I started the install of the Crimson 18 drivers and halfway through it jumps to the end and says it is done and doesn't even ask for a Restart. I Restart anyway and the Device manager reflects the update, everything runs fine but if I try to open the AMD Control Panel nothing happens and I get this massive issue...

https://imgur.com/5GtsVpF

Even after updating to the Crimson 19 or going back to the Crimson 17... Or even using 3DGurus Driver cleaner... Nothing is fixing this.. I have to End those to use my computer after trying to open the AMD Control panel otherwise my system is like it is going to crash... Any Ideas?


See More: AMD RX 480 Windows 10 64Bit

Reply ↓  Report •

#1
April 17, 2019 at 09:26:29
AMD calls its graphics driver package Adrenalin now. Is that what you're referring to? If not, uninstall Crimson & try Adrenalin.

https://www.amd.com/en/support/kb/r...

I would have everything pre-downloaded, boot into safe mode, then uninstall the drivers. If you don't feel the AMD uninstaller is good enough, use 3DGuru's or Revo Uninstaller, run CCleaner too if you like. Reboot & install the drivers.

message edited by riider


Reply ↓  Report •

#2
April 23, 2019 at 23:48:20
….Crimson was after Catalyst... Yes I meant the newer Adrenalin.. I even stated at the end that I already tried the Driver cleaner...

Reply ↓  Report •

#3
May 21, 2019 at 00:59:43
Still having the issue above in the picture. I actually ran DDU in safe mode which finally rid me of windows 10 trying to install old drivers but guess what? Still the same issue. Installing the latest drivers completes abruptly and it seems the drivers work no issue. When trying to launch the Adrenalin suite nothing opens and the two processes in the above picture eat up my CPU causing everything to crash. I have tried even older version 19 drivers with the same result.

As a note, the drivers windows 10 was installing work fine but they are super old like version 17.4


Reply ↓  Report •

Related Solutions

#4
May 25, 2019 at 19:40:14
@Toolpunk "As a note, the drivers windows 10 was installing work fine but they are super old like version 17.4"

^ There is your answer!

As you found out the newest drivers are not always the best!

*************************************
Dell Optiplex 780/intel Core2 Quad 3.0ghz/16gb Crucial DDR3L-1600/MSI GT-710 1gb PCIe/SB Audigy FX 5.1 PCIe/CM RS500/R3205-D/Win10 Pro 64bit


Reply ↓  Report •

Ask Question