XMS memory problem in MS_DOS VMWARE

January 30, 2019 at 17:36:51
Specs: Windows 10, xeon 2.6ghz e5 v2
Hello computing community. I been trying to install MS-DOS in my VMWARE workstation software. When I run certain programs, the os is unable to execute them and says something like: "not enough memory. memory needed 11000, memory required 15000. I saw several videos on youtube of people being able to run those programs in the exact same os. I've also notice that when I do the "mem" command it shows much lower XMS memory than what I saw on youtube and elsewhere on internet (around 14000 vs around 65000). I tried various versions of ms-dos but it's always the same. I would like to run dos 6.22 with supplemental disk (because I want the dos shell). Please do not suggest to use dosbox or freedos. I have a workstation with a xeon 2.6ghz e5 v2 with 32gb of ram. Thanks for your help.

See More: XMS memory problem in MS_DOS VMWARE

Report •

#1
January 30, 2019 at 18:20:53
Just curious, but have you seen this?:

https://communities.vmware.com/thre...

"Channeling the spirit of jboy..."


Report •

#2
January 30, 2019 at 20:06:26
Yes I saw that already. my memory stats are better but the programs still doesn't work

Report •

#3
January 31, 2019 at 07:17:25
How much RAM are you allocating to DOS? Try lowering it to 64MB.

Report •

Related Solutions

#4
February 1, 2019 at 07:43:49
I tried with 16, 32, 64, 128 and 512mb. from 64 mb it has the same xms memory and it does the same error when running certain programs.

message edited by SamyG82


Report •

Ask Question