Why does 486 board hang on DOS 6.22 floppy boot

December 18, 2016 at 10:26:38
Specs: Windows 7
I have a DTK PKM-5031Y 486DX33 motherboard with DTK 486 ROM BIOS Version 4.27 dated 4/29/93. No hard drive at this point just working on getting board running with dual 3.5 1.44mb floppy drives. The board posts without problem (Does have dead Dallas RT clock battery). DOS 6.22 hangs at "Starting MS DOS" booting from known working MS DOS 6.22 system disk floppy (without added devices or drivers). Dos 5.0 also hangs BUT for the heck of it I tried using DOS startup floppy disk from Windows 7 (VER returns "Windows Millennium [Version 4.90.3000]" and MSD returns MS-DOS 8.00) and the board boots right up and works fine. Does anyone have any ideas why I can't get DOS 6.22 (or 5.0) to boot from floppy?

See More: Why does 486 board hang on DOS 6.22 floppy boot

Report •

#1
December 18, 2016 at 11:10:31
Look in AUTOEXEC.BAT for a possible reference to C: or another drive than A: which I assume is your floppy drive. Either in a PATH command or in the beginning of a command line.

Use TYPE AUTOEXEC.BAT to check.

[Edited for typo]
Nigel

Wind slow

message edited by Nigel Spike


Report •

#2
December 18, 2016 at 13:42:45
Sir,


- At Start of Boot Process ("Starting MS-DOS ..." Message) Press <F5> And Bypass Config.sys/Autoexec.bat.
- At Start of Boot Process ("Starting MS-DOS ..." Message) Press <F8> And Control Config.sys/Autoexec.bat Load Process Step By Step.
- Swap/Change Floppy Disk Drives Cables (Swap A and B Drives cables/Connections) and check.
- Sometimes Floppy Disk Works in and with Floppy Disk Drive of Your System but it does not work with other Floppy disk drive of other system.
Try to USE The Floppy disk drive of the System that works properly With Your BOOT-DISK (Safe and true Boot Passed).
- DOS (MS-DOS and Compatibles, PC-DOS, NW-DOS/DR-DOS, OSx16, FreeDOS) Shows Source of Problem (By Message).
If You Don't See Any Message, Then Your Problem is System Crash Due To BAD-CODE Loading/Dumping !, USE TESTED FLOPPY DISK DRIVE,CHECK SYSTEM RAM, Check BIOS Settings For Floppy Disk Drive Type.

GOOD LUCK.

message edited by TechDOS


Report •

#3
December 18, 2016 at 13:54:35
First of all---you mention a dead Dallas battery. If you've not done so, then as soon as you boot, you'll need to make sure the drive types in the BIOS are set to 1.44MB. The motherboard is likely losing the configuration if you power-down (possibly changing the floppy specs to something like 360K or "none")

Second---you mention DOS 6.22 starts from your boot floppy but hangs on "Starting MS-DOS". It might be better to try booting from a true DOS installation floppy (Disk 1) or re-creating the boot floppy---insuring that the system files have been transferred after it's created (from the DOS directory of the machine that creates the floppy...type "SYS A:"...obviously without the quotes).


"Channeling the spirit of jboy..."

message edited by T-R-A


Report •

Related Solutions

#4
December 18, 2016 at 19:02:53
Thanks to everyone for answering!

Unfortunately the problem persists. I have already tried swapping out floppy drives and as well as booting from the original DOS install disks. I know the disks I'm booting from are good and have retested them - they boot several other machines without problems. I am not using CONFIG.SYS or AUTOEXEC.BAT files - just the basic system boot disks to start.

I did initially think the CMOS battery was a problem with drives being ID'd properly - the thing is, however, that I CAN boot MS-DOS 8.0 without any problems and the drives are recognized fine. I've also found I can boot from a Windows 98 dos startup disk - just DOS 6.22 and 5.0 hang on floppy boot (no CONFIG.SYS or AUTOEXEC.BAT). It seems strange that the older stand alone DOS versions won't boot on an ISA bus 486 board while the later windows bundled DOS versions do.


Report •

#5
December 18, 2016 at 20:30:10
Have you tried the disks in another computer? How did you 'retest' them to verify they're good?

I had that problem occasionally in the old days when putting computers together from used parts. It was always the disk. Attempting to boot a good disk in a bad drive can ruin the disk after one attempt. If you then used the disk in a good drive it would sometimes partially boot up and then hang, as yours is doing.


Report •

#6
December 18, 2016 at 21:15:54
Thanks DAVEINCAPS, but yes, I have tried the disks in other machines and they all boot fine. I've also made new MS DOS 6.22 system disks, but same problem - but only on this motherboard. Three other machines boot fine with the disks. The drives are good ( I did try swapping them out anyway) - I can boot MS DOS 8.0 or 7.10 and the board boots fine and I can run programs from the floppy drives without trouble.

The problem system is a bench set up DTK PKM-5031Y motherboard with 486DX33, Maxtor 110-00417 ISA IDE/Floppy controller, Diamond SpeedstarPro ISA VGA card and a Digital Research DRSERIAL2 ISA serial port adapter card. Two 1.44Mb floppies, no HD.

I'm thinking of trying another controller card - but it just seems odd that DOS 8 and 7.1 boot fine while DOS 6.22 and 5.0 won't.


Report •

#7
December 19, 2016 at 01:25:56
Might be bad ram then.

Does that motherboard really need an add-on card to connect the drives--no motherboard ports?


Report •

#8
December 19, 2016 at 20:51:42
Yes it's an ISA only board, needs add on cards for all I/O. RAM tests on boot are good and I can boot and run DOS 8.0 and DOS 7.1 then run DOS programs from floppy without problems.

Report •

#9
December 20, 2016 at 00:59:34
The ram count on bootup only checks that it's there; not that it's good. But yeah, the fact other versions run OK would seem to indicate the ram is good.

The hidden file msdos.sys is really just a placeholder in the versions that work. On 5 and 6.22 it's more sophisticated so if those versions have a problem loading maybe there's a problem there. But then since they boot OK on another system they would seem to be OK.

You say you're using 2 floppy drives. Try connecting one at a time and see if that makes a difference. But it ought to be either the disk or drive or both so I'm kind of at a loss to come up with something else.


Report •

#10
December 20, 2016 at 08:24:02
Thanks again for you help. I have tried single drive but same. Although I set the BIOS floppy drive settings each boot, I wonder if the dead CMOS battery is still causing some BIOS issue that gives the stand alone DOS versions problems. Unfortunately its a soldered Dallas real time chip so no so easy to deal with. Maybe I'll give the Dallas RT battery hack a whirl at some point.

Report •

#11
December 20, 2016 at 08:51:38
Hi Mike,
I cannot be certain, but I suspect the Maxtor IDE card.
Using later 'improper' versions of dos is maybe distorting the picture as they were not meant to be used freestanding.
Would think if you tried any version of authentic dos it would fail in same way.

Are you using that card anywhere else in the same way, and if so are the jumpers set the same. e.g. would expect the FD jumper to be set for PRIMARY

Regarding the floppy disk interface cable:-
a) end connector is for Drive A:
b):middle connector is for Drive B:
c) should be a section of cable twisted between (a) and (b)
See: .http://www.pcguide.com/ref/fdd/confCable-c.html

You would not be the first having difficulty setting it up:-
http://www.vogons.org/viewtopic.php...

Good Luck - Keep us posted


message edited by Mike Newcomb


Report •

#12
December 20, 2016 at 11:26:52
Sir,

mike584, Check and Test Your System With OSx16 Version 6.22 .
OSx16 Version 6.22 is Compatible with MS-DOS 6.22 (it is a Closed Source clone).
Also You Can Use, Run and Execute most of MS-DOS 6.22 Original programs under OSx16.
I Play Atari Games Included in OSx16 Boot-CD with My Old PC (Pentium 133) with ISA Creative SB16 Without problem (And BOOT-USB with P4, Also).
Test OSx16 BOOT-FD144, It May Help You To Find Source of Problem.

Google OSx16 (Bing/Yahoo/...) or Use this address https://goo.gl/8WtKXn

Good Luck


Report •

#13
December 21, 2016 at 11:18:07
Once again thanks to everyone! Cables and jumpers are all good. Tried a different "generic" controller with same result. I'll look into OSx16 as well. A friend has an ISA controller with on board BIOS which I'll try and see what happens. This seems to be a quirk with this particular motherboard. I swapped everything to a FIC 486-GVT-2 ISA board to test the card and floppies and everything boots fine with that board.

Report •

#14
December 25, 2016 at 13:27:48
Hi Mike,

have you tried using different slots in the mobo that is failing?

Good Luck - Keep us posted.


Report •

#15
December 27, 2016 at 22:28:58
Thanks, yes tried different slots to see, but same. Been busy with holidays so haven't tried much else in last few days - going to try IDE controller with on board BIOS once my friend gets around to loaning it to me.

Report •

Ask Question