Solved W98 boots but DOS refuses (as installed )

August 19, 2018 at 17:19:30
Specs: DOS622
Why does one HDD in particular allow me to install DOS but then hang before "starting ms-dos" but allow me to install W98 in its place and boot up happily? Not the jumpers. Bios happily recognises as master or slave - just wont boot. Reset configuration table "updated" but refuses still to boot in DOS. There seems to be something which W98 can do which DOS cannot to permit the boot process. CHKDSK and SCANDISK report no errors on the HDD

See More: W98 boots but DOS refuses (as installed )

Reply ↓  Report •

#1
August 19, 2018 at 18:30:00
What size HDD(s)? How much RAM? What is it you ultimately want to accomplish?

Reply ↓  Report •

#2
August 20, 2018 at 03:50:23
160GB WD IDE "NEW" (=reconditioned I guess). I am familiar with FDISK and the formatted partition was set active. What I want is to boot into DOS (622 preferred but not essential). I installed DOS using Microsoft installation disks on the blank original HDD and everything went fine (some unallocated space left over). Until the actual boot. It never says "Starting MS DOS" but hangs instead at that point. I can boot from a floppy at this point and go over to the C: drive, but not boot directly. In desperationI I try W98SE and that installs AND boots. I can't attribute the puzzle to anything other than W98SE knows something that DOS622 does not about how to get the BIOS to respond to the boot sector. When I did install the W98 it installed to the existing DOS C: drive and sidelined the DOS. It also warned me there was an OS on the drive to begin with. There is plenty of RAM available - sorry cant say at this moment how much.

Reply ↓  Report •

#3
August 20, 2018 at 05:08:49
✔ Best Answer
"There is plenty of RAM available"

What I was getting at is you may have too much.
See response #2: https://www.computing.net/answers/d...

"160GB WD IDE "NEW" (=reconditioned I guess)"

What size partition are you creating for DOS? Larger than 2GB?
https://www.computing.net/answers/d...
https://en.wikipedia.org/wiki/Compa...

message edited by riider


Reply ↓  Report •

Related Solutions

#4
August 20, 2018 at 09:59:59
I have another HDD running DOS (not "NEW") which works ok, boots up as requested. So I think the "too much" would cause that disk to fail to boot too. Otherwise it seemed an interesting new line for me to consider. Thankyou for the pointer. Regards partition, it is only the maximum DOS would allow when I installed 622 from floppy to begin with. Sudden thought ... there was no floppy to start with, but the bios accepted a USB floppy which I used to install 622 the very first time. I know DOS does not know about USB even though this did not prevent it from installing. Since then I put a floppy in and reinstalled but still no booting. I dont remember if I deleted and recreated the partition first.
The links you sent me are closely interesting. Thankyou. (Sometimes you dont know which question to ask for best help!) Just for now I am still puzzled by my issue but a bit more knowledgable.

Reply ↓  Report •

#5
August 22, 2018 at 00:04:11
A 160 FB Seagate drive loaded DOS and cheerfully booted up after installation. The problem must be associated with the drive itself, though why W98 should have worked when DOS 622 did not still puzzles me.

Reply ↓  Report •

Ask Question