sata controllers not seen by dos 6.22

January 3, 2013 at 10:54:21
Specs: Windows 7 x64, I-7 965ex/12G DDR3
creating boot dos floppy from usb floppy device (1.44mb) Must include generic sata controller drivers so that hard drive fat partitions and cd rom drives are acessable after floppy dos 6.22 boot. This floppy will then be used as a boot image for a cd rom with an iso section for tool files.
Floppy A emulation then
LH /L:3,27952 A:\mscdex.exe /D:mscd001
cd d:
switches=/n /f
devicehigh=A:\oakcdrom.sys /d:mscd001
devicehigh=A:\BTCDROM.SYS /d:mscd002
devicehigh=A:\gcdrom.sys /d:mscd003
device=A:\himem.sys /testmem:off /machine:1
device=A:\emm386.exe ram noems
shell=D:\dos\ D:\dos\ /e:512 /p

This does not allow the sata or usb controllers to work. I used usbaspi1.sys and when the driver polled the ports it would corrupt the disks partitions both usb flash and usb floppys

See More: sata controllers not seen by dos 6.22

Report •

January 4, 2013 at 01:47:19
One thing about your config.sys--himem.sys needs to be first and emm386.exe next. You're trying to load stuff in the upper memory before those files make it available. It's probably best to replace all the 'devicehigh' with 'device' in config.sys and the LH in autoexec.bat and let memmaker configure it all.

You have gcdrom.sys which allows dos to see most sata cdroms. I'm not familiar with a dos sata driver for hard drives. There was one thread on the subject on another site where the person said he used a regular win95 bootdisk and it recognized the sata drive on his laptop. But that doesn't make any sense.

Symantec's Ghost uses a dos format and works with SATA drives. I'm not familiar with that software but it may be possible to find out how they do it.

Report •

January 4, 2013 at 08:43:09
I was considering the order defiency, you are right. Typically memmaker is run after a dos instalation and is used to modify the autoexec/config files on [C:] root. Since it is 117kb I believe there is still room to fit it on the floppy and run it after boot to modify the current boot [A:] files. I Have a Ghost image V14...
mscdex.exe /d:nightowl /l:x /m:16 /v

device=oakcdrom.sys /d:nightowl

I will try this configuration from a floppy, it is possible that ghost.exe is what enables acess to sata hard drives. ohci/uhci ?

Keep you posted, quite a challange :-)

Report •

January 4, 2013 at 21:42:30
Yeah, it'd be convenient if they'd just add a sata-support driver in config.sys.

Here's that thread where the guy used a 95 bootdisk to see a sata drive:

That's the win 95B version with file dates of 8-24-96. He had some problems formatting but the main thing was his claim the bootdisk saw the sata drive. And as I mentioned above, I don't know why that worked--if it actually did.

Report •

Related Solutions

January 6, 2013 at 22:46:07
Food for thought. IDE to SATA bi-directional convertor cost about 10 bucks.

Don't these adapters force SATA drives to work as IDE ?

Report •

January 14, 2013 at 13:28:53
Many motherboards today do not have IDE or Floppy ports. The goal is to boot in to MSdos 6.22 with generic drivers that can access both sata hard disks and cdroms on any computer. Once a floppy is created that works then you extract it to a disk image and apply it to a cdrom (1.44 Emulation) to make it bootable (6.22) and then access any ISO data/tools that are put on the cdrom and any FAT16 HD partitions. DOS 6.22 drivers for FAT32 and NTFS partitions would be nice as well.
Thanks, Harry

Report •

January 14, 2013 at 15:02:46
wait - Just to clarify, you are trying to boot DOS 6.22 on a newer system with SATA drives, correct?
Ditto to picomode, i recently glanced on the inside of a win7 system bought last year and no IDE, barely even 4 PCI slots (3 open)
Be careful, DOS's incompatibility with multi-core systems can cause some nutty problems, believe me.
P.S you might want to set files to 40 if you ever plan on win 3.1, not that you need it.

Not everyone can decipher Klingon script...
chay' ta' SoH tlhe' vam Doch Daq

Report •

January 14, 2013 at 22:34:42
Yes Sata only using a USB Floppy. So far I have an sata ssd that under windows 7 I created a 2GB primary partition and made it active formatted FAT16 using partition wizard. boot from usb floppu 6.22 install and escape F3. use fdisk and can see the 2GB partition assigned drive "C" and other wierd stuff for my other drives like size
-167, left alone went back to prompt. sys c: system transfered then went back to windows and copied previously saved dos directory to the FAT16 drive. Restart and boots fine from Hd, various commands work fine like format, diskcopy. Dosshell from 6.0 works too. But while booted from HD fdisk halts system (remember worked booting from floppy) also the CDrom still does not work.(no drive letter assigned) The drive is empty but that should not matter. I will paste the start up files, Da menu program is installed.
LH /L:3,27952 C:\DOS\mscdex.exe /D:mscd001

DEVICE=C:\DOS\gcdrom.sys /D:MSCD001

As you see I am using "gcdrom.sys" which supports sata cd drives. I am running a ASUS P6X58D_Premium with a I-7 965ex, 12 GIG tri channdel ddr3 and the multi core does not seem to present a problem, my sata controllers are set to AHCI pass through. Have not messed with drivers for Marvel SATA III, NEC USB 3 controllers. A little over a week ago I was booted from floppy and ran fdisk attempting to add partitions to the FAT16 drive which damaged the partition on my windows SATA III SSD...OOPS :-) Good thing I have a back up image. So some how A:\ boot was able to access the SATA III HD to damage it?

Report •

January 17, 2013 at 21:21:56
I have narrowed the problem. When booting ms dos 6.22 from sata Cd drive and the sata controller is in ahci mode the handoff from bios to dos does not work. Since boot data comes from the Cd all you get is "non system disk". If you change in the bios the sata controller to IDE (compatibility) mode the boot cd works fine. Hard drives don't care about the mode as long as they have FAT16 partitions.

This gets complex.
I have a HD FAT16 2GB DOS 6.22 bootable with dos installed.
With the sata controller in ahci mode the bios hands off to the boot sector of the HD just fine, I use ahci.sys/mscdex to get drive letter access to the Cd drive.
CD 1.44 floppy emulation bootable and all needed files present. There is no access to the boot sector. "non system disk" Maybe the problem lays in the 1.44 emulation.
Maybe no emulation? Maybe Hard Disk emulation? Rather not consume drive "C" on Hard Disk emulation unless I can assign it to drive A and the usb floppy if present will get pushed to drive B.

Let me know if yo have any ideas.

Report •

Ask Question