Processor 80286 _ Application errors_urgently help needed!

September 8, 2017 at 03:03:59
Specs: 286, 16Mhz
dear people,
I am using a machine from the year 90’, which works with a processor 80286 ...
Everything so far worked well until the system showed me this message:

Resident portion of MODE loaded
COM2: 1200, e, 7, 2 , p
application error
, :-1:
,not, found not found matrix’
_c_’
Hit any key,

Can you clarify where the problem lies?
I would be very grateful!


See More: Processor 80286 _ Application errors_urgently help needed!

Reply ↓  Report •

#1
September 8, 2017 at 14:14:37
Does the computer really have 2 COM ports?
Do your really need to configure the serial port to 1200 baud?

You'll find the mode command on boot drive, e.g. C:\

If you don't really need this command, you simply can type rem at beginning of the mode line.
E.g.:
rem mode com2 1200,e,7,2,p

If you need to configure the com port but there is only one com port available, change the mode config line in autoexec.bat to com1 instead of com2.


Reply ↓  Report •

#2
September 8, 2017 at 15:02:48
thank you for your ranswer
yes the computer have 2 COM ports and I need the mode com2 1200,e,7,2,p
I have the application named matrix there (I am not an expert on this type of computer but this computer is accually related to a machine which have only one task so I think this application in COM2 is important)
could it be that the hard disk C: is brocken, what do you think?

Reply ↓  Report •

#3
September 8, 2017 at 15:55:01
I don't think, that the harddrive is broken.

Sounds more like the com port, the cable from com port to the machine, or the machine itself, which is controlled by the matrix software is broken.

Have you checked the cable connection at both sides?


Reply ↓  Report •

Related Solutions

#4
September 9, 2017 at 03:28:53
Hi Sof,

Has it ever worked?

When does the display occur,
when the pc starts or when the Matrix runs?

What exactly does the Matrix application do?

What are you connecting to COM2 that Matrix communicates with?

You can change the MODE settings when the PC is running, not just with AUTOEXEC.BAT when it starts

Seven data bits does not sound correct.
Usually 6 or 8 are used.

Good Luck - Keep us posted.

message edited by Mike Newcomb


Reply ↓  Report •

#5
September 9, 2017 at 03:48:31
Hi guys,
thank you for your answers
it workes since like 25 years without any problem
I think the Matrix is an application to convert/ run the data of the machine in the computer.
The COM2 is connected to the machine.
How can I change the MODE settings when the PC is running without removing the matrix application?

Reply ↓  Report •

#6
September 9, 2017 at 04:09:52
You can't change the MODE settings, while the matrix is running, because DOS does not support Multitasking.
So you have to stop the matrix program an make the changes in c:\autoexec.bat for permanent changes, or you have to type in the Mode command on dos prompt.

But, as you mentioned, it worked for 25 years.
So I sure, it's not the MODE setting, that causes the problem.

As mentioned in #3, check the cabling, try using another com port.
If you're using another com port, you also have to make the MODE settings for e.g. COM1.


Reply ↓  Report •

#7
September 10, 2017 at 04:57:33
Hi Sof,

I agree with Paul above, however if the Cable has *NOT* been disturbed, I suspect the cause is more likely to be one of the 2 Serial (COM) Ports. There is one at each end of the connection.

A breakout box might help as it allows you to view the hand shaking involved.

However, reading the display again it may be unrelated to the MODE
activity and simply appearing after MODE has actioned correctly..Do you have any Matrix documentation which perhaps provides a meaning for the error message.

Am surprised after 25 years you seem unable to detail exactly the task(s) Matrix performs or the equipment used. If such tasks are important, it is wise to have standby equipment and use such occasionally.

Electronics fail and 25 years service is exceptionally good.

As a matter of interest where (City/State) are you located?
I am in West London.

Good Luck - Keep us posted.

message edited by Mike Newcomb


Reply ↓  Report •

#8
September 10, 2017 at 06:38:57
Such old computers needs to be virtualized.
New computers do not have serial ports anymore, but one can by an adapter from USB to serial port.



Reply ↓  Report •

#9
September 11, 2017 at 09:44:03
I checked all the cable and port
they are ok
there was an AA Battery 3,6 V
I checked it after taking it out
and now I have another problem

Drive C: 1,44M RAM Disk unformatted (w)
Battery is Good

How can I solve this problem?


Reply ↓  Report •

#10
September 11, 2017 at 09:45:01
I checked all the cable and port
they are ok
there was an AA Battery 3,6 V
I checked it after taking it out
and now I have another problem

Drive C: 1,44M RAM Disk unformatted (w)
Battery is Good


Reply ↓  Report •

#11
September 11, 2017 at 15:10:01
Generally drive C: is the first harddrive, that is installed on your computer.
Or is there no harddrive installed on that computer and starts up from e.g. floppy drive?

So maybe, the computer had been started from floppy drive.
And in autoexec.bat, there may be a command, to create a RAM Disk and all files, needed for the matrix will be copied to it.

So after that, you can remove the floppy disk, cause the system is running from RAM Drive.

But, on reboot, you need to insert the floppy disk into drive, to boot up your system properly.

It's just a guess.


Reply ↓  Report •

Ask Question