Solved Old DOS program runs on some computers only

February 4, 2019 at 05:58:31
Specs: MSDOS 6.22, AMD/Intel
Bit of a conundrum. I'm trying to get an old DOS program to run on a modern laptop as it's part of a very large expensive bit of kit for engine testing tractors (dynamometer). I've got many hurdles to jump on this so I'm testing each step on the way to knock them off one-by-one.

I have MSDOS 6.22 booting off a floppy on my desktop and the application works (just to check the program works 'though not connected to the dynamometer). I can then get DOS to boot from the floppy using a USB floppy drive to my Lenovo laptop. DOS works fine but the application starts to load then stops with just a blinking cursor.

I've done quite a lot of searching on this but to no avail. Can anyone shed some light? Thanks.

See More: Old DOS program runs on some computers only

February 4, 2019 at 06:19:54
✔ Best Answer
Many old or very old DOS programs do have such issues.
And if such programs do start correctly, they get timing problems on measurements.

So I suggest to run the Program in a virutal machine, running DOS inside the virtual machine.

Maybe that helps.

Report •

February 4, 2019 at 07:50:28
"run the Program in a virutal machine, running DOS inside the virtual machine."

Even better, find an old machine from the era of the software. Many old custom programs want to control ports, and that's very cumbersome under a VM.

"Channeling the spirit of jboy..."

Report •

February 4, 2019 at 12:39:30

You might be right, but it's easily tested and worth, to give it a try, before searching for a real old computer.

If the program will work in a VM, the OP is independend of old computer hardware.

Report •

Related Solutions

February 5, 2019 at 14:07:35
Hi Guys and thanks for your comments. I did wonder about a DOS box or VM except it involves installing it on one of my employers' machines and they're a bit funny about that, which is why I was trying to debug on my own machines with the hope of booting into DOS from a USB stick.

Not only that I've got to resolve the issue of getting the program to communicate with the dynamometer through a USB to serial adapter, but that's for later! I take your point about finding an old laptop, but when I inquired, they recently had had a clearout of old junk!!!

Not given up yet... I'll keep you posted as to how I get on.


message edited by wharfhouse

Report •

April 11, 2019 at 02:52:27
Hi Guys,

Sorry it's been a while, but just wanted to let you know how I got on with this problem as it's now resolved (yea!)... may help others in a similar situation.

The solution was to use DOSbox originally on an USB stick as a trial with the dynamometer DOS program with it. With NO tweaking this worked on the Windows 10 64 bit laptop "straight out of the box".

I then transferred the whole folder to the laptop, checked again, perfect. The final hurdle was then to get a USB to serial adapter cable for Windows 10 to recognize. I acquired two: one with an FTDI chipset and one with a Prolific chipset. Research told me that DOSbox was unlikely to work with the FTDI due to timings. However, both cables were recognized by W10, drivers downloaded and com ports noted.

With the FTDI cable, this proved to be not the case as, after tweaking the DOSbox config file, worked perfectly when plugged into the dynamometer and a tractor on test. Brilliant!

So job done and well done DOSbox. Thanks again for all your help and support.


Report •

Ask Question