No output from COM1 under DOS but ok in Win98

September 2, 2011 at 10:46:41
Specs: Windows XP
I need to communicate with another computer running MSDOS via serial connection. The COM1 port works fine in Win98 but if I reboot to MSDOS I see no output or input. I have checked all the settings and they seem correct.

What would keep the post from working in DOS but work fine in Win98.

This is a IBM ThinkPad laptop. I have disabled the IR since I was told it tends to take the COM port.

Thanks,
Greg


See More: No output from COM1 under DOS but ok in Win98

Report •

#1
September 2, 2011 at 22:36:21
In dos, what software are you using to communicate between the 2 computers?

Report •

#2
September 3, 2011 at 01:04:59
Hi Gwandless

Presume you are using a cable to connect the two computers.

If so, the pin connections are important.

From memory, I think around 6 wires are required. Only one or two are one to one connections.

The pins used differ, depending on whether a 24 or 9 pin rs232 (d type) socket is being used.

As a matter of interest, where are you based. I am in Hammersmith, West London.

Good Luck - Keep us posted.


Report •

#3
September 6, 2011 at 05:18:13
Hi Mike,

I am in Sterling, VA.

A little background, I had this setup working at one time between two computers. When I first tried doing this there seemed to a conflict between the IR com port and COM1 once I disabled the IR port I had communication between computers.

I got a used HP Pavillion to replace the Dell laptop that I was borrowing from work. It does not have a dedicated 9-pin connector, so I had to go the way of USB-to-Serial cable. Other people who are doing the same thing have successfully used this method to communicate between Win on one and MSDOS on the other, so I don't think its the cable.

I have successfully done this hookup between my HP running Win7and a Gateway Solo running MSDOS, so I am sure its something funky with the IBM Laptop.

Just to let you know whats going on, I am running a laptop under MSDOS to control software that controls the movement of a telescope, the Windows computer sends command to the control software to tell the computer wher move to.

One more thing if I run MSD from DOS on the IBM the ports settings are completely different from the settings setup when the IBM is in Win98, so something is flaked up in DOS.

Since the two computers communicate fine when they are both in Windows I am sure there is nothing wrong with the ports so when I reboot to DOS mode something happens to the settings for the com port.

Thanks for any help,
Greg


Report •

Related Solutions

#4
September 6, 2011 at 06:55:35
Hi Greg - when booting in dos:-

a) has the MODE command been used?

If so, it may be changing the serial port settings.

b) check config.sys and autoexec.bat for anything appertaining to the serial port, that may be changing its settings.

c) the program running on the dos machine has to 'know' which port it should use. Have you checked this?

Good Luck - Keep us posted


Report •

#5
September 6, 2011 at 07:21:23
What model IBM are you using and also what dos ver ?

Keep the old stuff running


Report •

#6
September 6, 2011 at 08:53:30
Mike,

I have tried the MODE command with no luck. I'll check config and autoexec. The DOS program knows which COM port to use, its assigned to COM1 in its config file.

Linux,

Not sure which IBM ThinkPad Model it is I think I remember it being s T20 if that sounds right, I'll check tonight. I have Win98 loaded so which ever version of DOS comes with 98.

Thanks,
Greg


Report •

#7
September 7, 2011 at 06:56:25
Finally solved my problem, the key is to boot straight to DOS not windows and set COM1 parameters in autoexec.

Thanks for your ideas.

Greg


Report •

#8
September 7, 2011 at 20:27:20
Seems like you're adding new info with each posting. The fact you weren't booting straight to dos changes things. If you don't want windows to alter the bios port settings then change the 'PnP OS' option in cmos/bios setup to NO or NONE. (It might also show as an OS option for windows 95. If so, change that to DOS.)

Report •

#9
September 12, 2011 at 08:35:22
I have a T20. I looked in the BIOS config setup and could not find any setting PnP. Where might I find it?

Report •

#10
September 12, 2011 at 18:56:30
If it doesn't ask if you're using a PnP OS then it might ask about a specific OS. Windows 95 or 98 would be a PnP OS. Dos would not be a PnP OS. If you tell the bios you have a PnP OS then it will allow the OS to alter some of the port settings. If you tell it you don't have a PnP OS then it won't let the OS change any settings.

That option may not be there. I assumed it was since you said some of the port settings were altered. You may need to consult the manual if you're not sure.


Report •

Ask Question