Need help with Dos on Epson Action Note 4SLC/33

September 3, 2016 at 10:10:48
Specs: Dos 6.22, 486 33MHZ
I recently acquired a Epson 4SLC/33 and the hard drive as detected by the bios, but when i got a dos install disk dos couldnt see my hard drive and ive tried many different configs in the bios but nothing works. I have also swapped hard drives from a working 486 laptop and it wouldn't boot off of it even tho its the same type of hard drive. The HD im using is a Toshiba MK1552FCV. Any help would be greatly appriciated!

See More: Need help with Dos on Epson Action Note 4SLC/33

Report •

#1
September 3, 2016 at 14:07:57
First problem is that you've hooked a drive (120GB if Google is correct) to a machine that's made long, long before that size drive was directly supported by the machines' BIOS. It may report that the drive is there, but it likely doesn't natively support anything that large. During the era of 80486 machines, some would support drives up to about 2.1 to possibly 8.4GB, but more than likely, it's native support is for something 528/540MB or less. For it to possibly ever support that large of a drive, then you'd at least need a disk overlay program (and that possibly may not even work). You also mention you've swapped drives from a working 486. Did the drive geometry set up properly in the BIOS? And if so, are you certain the drive controller on the machine is working?

Second problem is that MS/PC DOS isn't designed for large drives either. Versions of DOS greater than 4.0 would only support a single partition as large as 2.1GB, and actual physical drives no larger than 8.4GB (see links below).

You'd likely do far better (at least in getting DOS running) by trying to find a drive in the 120-500MB range than the 120GB drive that you're apparently trying to use now.

https://www.win.tue.nl/~aeb/linux/L...

http://www.pcguide.com/ref/hdd/bios...

http://www.pcguide.com/ref/hdd/bios...

"Channeling the spirit of jboy..."

message edited by T-R-A


Report •

#2
September 3, 2016 at 14:39:24
Thanks for the reply and the drive is a 120mb according to the sticker on the HD. I have manually put in the geometry of the HD and it still didn't work. The HD controller works cause the laptop has a format feature and dead sector tool on the bios and it will format it and find bad sectors. But, it still could be the controller.

Report •

#3
September 3, 2016 at 19:17:09
What version of dos?

You say dos doesn't see the drive. Run FDISK from the dos disk you're booting from. Do you get an error message? If not what does fdisk option 4 say?

How sure are you the drive is good? It's good the bios sees it but that's no guarantee it's good.


Report •

Related Solutions

#4
September 3, 2016 at 19:34:03
Check that model number again. That does come back as a 120 gig but it has no drive geometry on the label:

https://www.pchub.com/i/Toshiba-MK1...

What cyclinders/heads/sectors info is on your label?


Report •

#5
September 3, 2016 at 20:12:04
When I Google the HD it comes up as a 126mb HD. And I've tried fdisk and it comes up as no fixed disks found.

http://www.cnet.com/products/toshib...


Report •

#6
September 3, 2016 at 21:38:16
The drive you just linked to was MK1522FCV; the model number you posted originally was MK1552FCV. Oh well, another episode ol 'fun with typos'.

What version of dos are you using? Older version may not see the drive correctly.

I assume the drive has no external jumpers since it's a laptop drive. Unless the bios isn't seeing the drive's full capacity use 'auto detect hard disk' in bios setup as sometimes the drive geometry on the label doesn't account for drive translation that some bios' use.

Edit Oh I see your specs say dos 6.22. That version ought to see it OK. The drive connection to the laptop is good? I guess fiddle around in bios setup a little more but otherwise maybe the drive is bad.

message edited by DAVEINCAPS


Report •

#7
September 4, 2016 at 04:53:37
It does have 4 pins with no jumper connected and it says to have no jumpers if you want it to be a master drive. I've also tried different cables, so I'll get a different drive and try that. Thanks for the help!

Report •

#8
September 4, 2016 at 14:54:22
You're welcome. I hope it works out.

Usually if the bios sees a drive, fdisk will at least give an 'error reading fixed disk' meaning it knows you've got one but is having a problem with it. I don't understand why it's not seeing the drive at all if the bios says it's there.

In your original posting you said 'I have also swapped hard drives from a working 486 laptop and it wouldn't boot off of it even tho its the same type of hard drive.' Does that mean you swapped the drive out of the Epson and into the other computer and you had the same problem? If not you might try that. We know the other computer will work with that model drive. Try setting up the Epson drive on the other computer and see what fdisk says. If fdisk recognizes it then the problem is likely with the hardware on the epson and not the drive.


Report •

Ask Question