ms dos 6.22 cd won't boot if sata controller is in ahci mode

January 17, 2013 at 14:09:09
Specs: Windows 7 x64, I-7 965ex/12G DDR3
ms dos 6.22 Cd won't boot if sata controller is in ahci mode
CD boots fine if controller is in Ide mode, otherwise I just get "non system disk"
I have ahci.sys that provides sata Cd acces in AHCI mode when booting ms dos 6.22 from floppy.
the Cd boot sector is ms dos 6.22 and when AHCI controller mode and when the bios hands off the system halts.

See More: ms dos 6.22 cd wont boot if sata controller is in ahci mode

Report •

January 18, 2013 at 03:52:45
The problem is that you are booting from a floppy disk to load the ahci.sys driver into memory, then your are restarting your system to boot from a CD.

When you restart your system to boot from the CD, the existing data in memory (the ahci.sys driver) is lost.

Report •

January 18, 2013 at 09:42:03
There is a misunderstanding...
I have built a floppy that boots in either ahci or ide sata controller mode.
I use both drivers..gcdrom.sys (ide) ahci.sys (ahci) depending upon the state of the controller ONLY ONE of them errors out. ie... "no drive found" This way in either mode I get Cd drive letter assigned with access.

I then burn a bootable Cd (1.44 emulation) using the floppy as boot image. I am then able to put up to 700Mb in the iso data section of the Cd.

I then boot from this Bootable Cd with the sata controller in IDE mode and it works fine. Full boot with with Cd access.

I then only change the sata controller to AHCI mode and try to boot from the same Cd when the bios is finished I get "non system disk, press any key"

The problem is that when the bios hands off the boot process to the Cd Ms Dos 6.22 can't handle (probably IO.sys) ahci Cd access and therefore does not even load.
I have also obtained an image from (DOS6.22_bootdisk.iso) that has the same result.. works with sata controller in ide mode but not in ahci.

One thing to keep in mind is that ahci.sys is a Cd driver used with mscdex.exe not a controller driver. I have a sata hard disk that is bootable (Ms Dos 6.22 2GB-FAT16 partition) with access no matter what mode the controller is in or what method I boot from ie..Hd, Floppy, Cd except Cd ahci controller mode.
[AHCI] mode booting
[Hard Disk] ahci.sys provides Cd access.
[Floppy] ahci.sys provides Cd access.
[Cd] no boot

[IDE] mode booting
[Hard Disk] gcdrom.sys provides Cd access.
[Floppy] gcdrom.sys provides Cd access.
[Cd] gcdrom.sys provides Cd access.
oakcdrom.sys works with my Samsung Cd/DVD-RW drive, gcdrom.sys is a more universal driver.

Report •

January 24, 2013 at 16:23:32
Asking me to select best answer? I don't think there is a solution, it is a ms dos 6.22 limitation. With SATA controller is AHCI mode all Ms Os's working backwards up to and including Win 95b will boot from Cd. Win 95a says I/O error. Haven't tried any earlier version of Windows ie...3.1. Ms Dos 6.22 says non system disk. I know that the operating systems are being queried but refuse to communicate through the
Cd Drive with the controller in AHCI mode. USB Flash and Floppy boot just fine in either mode (AHCI/IDE) as well as the SATA Hard Drive. Cd also works if Controller is in IDE mode. Just one limitation Cd/AHCI no go.

Report •
Related Solutions

Ask Question