Installing DOS 3.2 on an IBM XT (5160)

Fujitsu / S6010
April 6, 2012 at 16:16:34
Specs: DOS, 8088
Hey all,

I recently acquired an IBM XT 5160 from a friend of mine and got it running with a somewhat major error involving its Seagate ST-225 hard disk. Just to clarify, the drive was working before several times when I was showing it off. Being extremely tired one night, I took the PC apart to clean it out and my mistake was in using a screwdriver with a magnetic-tip to unscrew the housing and reposition the drive. Now when I fire it up, the drive makes a click of death noise after 2 seconds, makes a few small seeks, then clicks again for 10 seconds until it stops and makes a relatively quick (1-2 seconds) seek test over the entire disk. And the IBM can't read from the disk so I believe I screwed up the MBR.

Now that I got my hands on some old DOS disks, I can't get it to install since it doesn't recognize the drive. However I didn't touch anything like the logic boards except for taking the drive out and then putting the cables back in the board below it. So my question is: is there a way to fix the drive to boot either by something like inserting the disk board into another slot, or is the drive just dead (as best as you can think of from my description)?

Thanks for reading this. I'm sorry that was so long.

--Todd


See More: Installing DOS 3.2 on an IBM XT (5160)

Report •

#1
April 6, 2012 at 16:57:38
If the MBR or formatting was damaged you need to low level format the disk. I use to use debug then enter parameters. The physical parameter are in the hard drive controller ROM and sometimes jumper selected. I used WD-1003 controllers mostly. Some factory XT's came with Xebec controllers. Then partition and format as usual. They were utilities to do it. But 30 years is long ago.
The Seagate ST-225 was not the original disk with the 5160.

Report •

#2
April 6, 2012 at 17:20:42
Thanks! I just tried running DEBUG with the low-level formatting address "C800:5" which brings up a WD format utility. I haven't looked at the controller board yet but I tried the utility and entered the disk drive number. Unfortunately it still makes the same noises and doesn't access the disk. The utility freezes after the disk interrupt with the error code "1701" (disk error). Is it possible a terminator can be causing this issue?

Report •

#3
April 6, 2012 at 21:56:37
Possibly but not probable. If the drive uses a servo track and it is damaged a servo writer is needed to repair. Best to try another drive.

Report •

Related Solutions

#4
April 6, 2012 at 23:19:07
Just a thought - is the drive actually spinning? (You can normally hear directly with these old drives; if not put a screwdriver blade on the drive and your ear against the other end - acts like a stethoscope.)

These old drives were very prone to "stiction", where the head gets stuck to the platter. Most of them has a flywheel that you could turn manually, or by inserting a small screwdriver in a slot. If you can't hear the drive turning try turning it very gently (clockwise when viewed from below if IRC) to free it.

If that is the problem then it will almost certainly keep happening, in which case you'll need a another drive. I very much doubt you can find a new one anywhere, but eBay is your best bet for a pre-owned one.


Report •

#5
April 7, 2012 at 11:09:13
The drive is spinning since I hear the servo powering up and winding down when I kill the power. I feel like it's an issue with the logic board though since I opened the PC and noticed that when I disconnect the cables to the controller board, it still makes the same noises when only power is supplied to it. I unscrewed the logic board from the bottom of the drive to see if anything "looked" broken but everything seems fine.

I found a YouTube clip of the ST-225 powering on (not my video) and it makes the same noises when starting up. Just curious if the sequence of noises might indicate an error with the logic board and whether the drive should be trashed. Thanks!


Report •

#6
April 7, 2012 at 12:08:58
Far easier to damage than the circuit board on a hard disk is the data cable. Position it wrongly and you can break one of the connectors. I've had that happen to me before now. Examine it closely and look for any breaks.

To address your OP, I don't think a magnetized screwdriver would damage a drive. Did you unplug any of the cables? Are you sure they are all firmly seated, and that the connectors are the right way round? And is the controller card firmly placed in its socket. (BTW, when you next have the case open push all the RAM chips firmly. They have a habit of "walking" out of their sockets over time; I think it's due to thermal expansion.)

If it's not the cabling then almost certainly it is the drive, but I'm sure it's just a coincidence that it happened when it did.


Report •

#7
April 7, 2012 at 12:36:42
In your first post you mention unscrewing the housing and repositoning the drive. Does that mean opening the drive case?

Report •

#8
April 7, 2012 at 18:57:13
The drive case wasn't opened. I just unscrewed these two screws holding the drive in place within the housing.

I'll also take a look at the connectors again. I unplugged the cables when moving the drive since I wanted to inspect it from underneath but they're the only two ribbon cables leading out of the controller board which I simply reconnected to the drive. I think the RAM chips are well-seated but I'll take another look.


Report •

#9
April 7, 2012 at 22:19:57
Okay so I think I got the drive formatted. It's very strange but applying a little pressure to the drive made the WD format utility recognize the drive and I just entered the disk geometry info and it began formatting the drive. The drive doesn't make that noise when booting up now but now the issue is getting the IBM to recognize it since it shows up as "1701" and DOS doesn't recognize the drive.

Is there something I need to flip (e.g. a DIP switch or jumper) on my controller board or on the motherboard to get this working again? Thanks again for all the help!


Report •

#10
April 8, 2012 at 01:25:23
http://vintage-blog.peacon.co.uk/wi...

Googling is quicker than waiting for an answer....


Report •

#11
April 8, 2012 at 07:26:49
Very true, Jolicloud. I was just wondering if anyone knew a quick fix off the top of their head.

Report •

#12
April 8, 2012 at 20:00:09
Pushing down on top of the drive worked for me once:

http://www.computing.net/answers/wi...

(Have I been around here a long time or what?)

but the drive only works right when pressure is applied; it's not a permanent fix.


Report •

Ask Question