IBM PS/1 Not recognizing CF IDE Drive

February 8, 2020 at 10:23:07
Specs: DOS 6 / Win 3.1, 486 / 64MB
Hi I recently bought a Monoprice IDE to Compact Flash adapter and a 2GB Verbatim CF Card to use as a secondary/slave drive with my IBM PS/1 2168.

I wish to keep the original IBM H3256-A3 IDE HD as the master and the CF card as the slave. I had set jumpers on the CF adapter to "slave" but my computer does not recognize the drive when the IBM HD is connected. When the IBM HD is disconnected, the computer does see the CF card.

When I enter the BIOS, it lets me select "Installed" for secondary Hard Drive, however each time I reboot, it reverts back to "none" (I tried this several times, ensuring I saved my changes).

Any help getting my CF card to work with my HD is greatly appreciated!

Thanks!


See More: IBM PS/1 Not recognizing CF IDE Drive

Reply ↓  Report •

#1
February 8, 2020 at 11:53:16
Experiment with the drive config. If you're using separate IDE channels/cables, try setting both drives to primary. HDD = primary master; CF = 2ndary master. If they're both on one cable, the HDD should be on the end connector. If Cable Select is available, try setting both drives to that.

message edited by riider


Reply ↓  Report •

#2
February 8, 2020 at 14:58:24
CF adapters and cards can often be tricky to get to work. Suggest you look at this (it's not Mac-specific):

https://lowendmac.com/2015/the-lowd...

...and this:

https://www.vogons.org/viewtopic.ph...

"Channeling the spirit of jboy..."

message edited by T-R-A


Reply ↓  Report •

#3
February 8, 2020 at 15:31:13
Both drives are on the same cable, and the IBM drive is on one of the ends. I tried positioning the CF reader on the middle of the cable (was originally on the other end). And again played with the jumpers (master / slave) and have had no luck still. So I'm not really sure what do do next.

Reply ↓  Report •

Related Solutions

#4
February 8, 2020 at 17:28:58
I think that adapter only has 'master/slave' options. If so, recheck the jumpers on the hard drive. If they're set to CS (cable select) change it to 'master'.

message edited by DAVEINCAPS


Reply ↓  Report •

#5
February 9, 2020 at 09:50:21
I don't think 80-wire IDE cables were available when that system came out but it wouldn't hurt to try one.
http://oldcomputer.info/pc/ps1_2168...

Reply ↓  Report •

#6
February 10, 2020 at 00:52:45
Hi Big,
as this is a dos os, I am wondering if the size of the device is the problem.

Believe changes to both autoexec.bat and config.sys are required, in order to work.

For info, Google:

dos large disk support

Good luck - Keep is posted.

message edited by Mike Newcomb


Reply ↓  Report •

Ask Question