I want to read old ms dos hard disks

November 25, 2014 at 10:22:19
Specs: Windows 7
Hi

What do I have to do to be able to read old (early 90s) hard disks from my old business?

(to make 100 characters...)

What do I have to do to be able to read old (early 90s) hard disks from my old business?


See More: I want to read old ms dos hard disks

Report •

#1
November 25, 2014 at 11:40:12
Windows should be able to read them, if you can find a way to connect them to your computer. Assuming they are IDE disks that shouldn't be too difficult. If they are older MFM ones it will be considerably more difficult.

Do you have make(s) and model no(s). For the disks?


Report •

#2
November 25, 2014 at 12:42:20
Hi

many thanks

I'm afraid I have the hard disks elsewhere abroad an will not be there until Xmas. I hope you'll still be around by then...

What I have here are the Operating System floppies Microsoft MS-Dos Version 4 (there might be another version elsewhere) and the Programme I used: DataStar.

My old office computers were "something 86".. Does that make sense?


Report •

#3
November 25, 2014 at 14:01:13
Ah, of course, the program used is also important! Still, as you have that, no problem.

The main question will be whether you can connect the hard disk to any computer that you have. Post back when you have the disks and I, or someone else, will see what we can come up with.

I certainly hope - God willing! - that I'll still be around by Xmas. :)


Report •

Related Solutions

#4
November 25, 2014 at 18:52:32
If the 'something 86' was the cpu then it likely was pre-pentium--a 286, 386 or maybe 486. But whichever it is, what matters most is the type of drives they are.

Report •

#5
November 27, 2014 at 11:56:20
hi Qim,

as advised above, the first step is physically connecting the hard disk or disks.

However, possibly to then read the files, you will have to use your Datastar program.

I am do not know this program - is it a dos program - what does it do?

You may run into problems running on a modern computer, more so if printing is required, as these old programs were not forward compatible. However we will cross that hurdle when you arrive there.

Good Luck - Keep us posted.


Report •

#6
November 27, 2014 at 12:08:09
Hi Mike

Thre was a family of ptogrammes: Dtastar, Infostar, Wordstar, etc. Datastar was amazing. It allowed you to programme in Dos and I managed to get it to do everything in the office, bar sweep the floor at night.

I need to get access to the company accounts. I would be happy to dedicate an old computer (Toshiba around 2002) to this. As you said the first step is to connect the drive to the Toshiba as an external drive, I suppose. I have the original Datastar floppies and I think I have them also in diskettes. I expect that I have also the Dos Operating system disks. I take it that if I format the Toshiba, I could then install the Dos OS. Yes? No?

Thanks for the interest.


Report •

#7
November 27, 2014 at 23:12:51
What version of dos do you plan on installing? Pre-windows versions could only create and see partitions up to 2 gig and I think versions before 6.0 couldn't see that much. Also dos won't natively recognize SATA drives or external USB drives.

And, as already mentioned, a lot depends on what kind of drives the files are on. If they're older MFM or RLL drives you won't be able to connect them externally to any computer.

If they're IDE drives you can probably just connect them as internal drives and boot from them. Dos doesn't care if you move a drive from one computer to another, as long as they're correctly configured in bios setup.


Report •

#8
November 29, 2014 at 06:32:22
Hi Qim, I still use Wordstar as my WP program - wonderful program, although I do not use the final version that had limited Mouse support. (anyone out there with v7.0d?) Had a bit of a struggle to overcome it appearing in a small window, but it worked fine under W2000 and lately WXP.

I did not mention connecting externally. If they are IDE interface, it is easy to connect internally. Make and model number will be used to identify which interface they have.

Possibly the easiest way to access these accounts is to set up everything on the oldest pc you can find. Maybe the hard disks you have already have a dos os on them. Which probably will run is the disk is used as the master. I would use dos 6.2n, which is better then earlier versions.

The reason I warned of potential problems with printing is that each dos programs came with its own set of drivers, and early ones did not include lasers etc.

Perhaps you might advise why you wish to access the (very) old accounts.

Good Luck - Keep us posted.

message edited by Mike Newcomb


Report •

#9
November 29, 2014 at 07:42:17
Hi Thanks

I posted an earlier message in reply to Dave but it vanished...

I will come back when I get hold of the disks probably in just over 2 weeks. many thanks


Report •

#10
December 17, 2014 at 23:09:06
Hi
Here I am with the drive details There are 4, but if I remember one did not work

Seagate Mod ST1150R
Quantum ProDrive 210A
Quantum ProDrive LPS
Hitachi (can't read the small letter at the moment)

They were all working at the same time, so I assume that the connectors were all the same

message edited by qim


Report •

#11
December 18, 2014 at 01:17:28
The seagate looks to be an RLL drive with the older ST506 connections. I assume when looking at the back of the drive it has two slide-on connections?

The quantum 210a is IDE and the LPS could be either IDE or SCSI (there should be more numbers and letters after the LPS). But you can probably tell just by looking at the back of the drive.


Report •

#12
December 18, 2014 at 02:09:02
Hi

The Seagate has two sockets, one with about 20 holes, the other aound 34. The leads are still attached. By holes I meant part of the leads, which of course fit into pins!)

Both Quantum have one one of around 39 pins and another of just 4 pins

The Lps does not say anything else of value but there is label that says 105AT

The Hitach just one connector of around 50 pins

message edited by qim


Report •

#13
December 18, 2014 at 12:40:40
I can't tell from your explanation of the seagate what its connections look like. It should be the typical MFM/RLL connection. There's a picture of that connection on this page about half way down:

http://community.futuremark.com/for...

It's got the two slide-on connections at the bottom. If that's what it is you're going to have a very hard time setting it up. You'll need a 16 bit ISA RLL controller card and an older computer--probably a 486 although you may be able to use an older pentium I.

The quantum drives are IDE and should connect to any computer with IDE ports, although if they came from an older computer they may have been identified in bios setup as a particular drive type rather than auto identified. In that case you may not be able to access the drive unless you can figure out what drive type it was originally set as.

If the hitachi has a single 50 pin connector then it must be SCSI and you'd need to connect it to a SCSI card in order to access it.


Report •

#14
December 18, 2014 at 15:43:35
Hi

I could send a picture of the drives. Is it possible to upload them in this forum?


Report •

#15
December 19, 2014 at 00:36:21
No I don't think you can. You'd have to upload them to some sharing site and post a link. It's probably not necessary unless the seagate is different than the picture in my link above. If you can get an exact model number on the hitachi that would help but as I mentioned it's probably a SCSI.

I'm sure the quantum are IDE. You should probably concentrate on those first since virtually all computers have IDE connections. You mentioned connecting them externally. If I was doing it I'd connect them one at a time as a secondary internal drive in a desktop computer but I don't know what kind of setup you have.

Then I'd have them auto identified in bios setup and boot the computer from the primary drive and from there see if the added drive could be accessed. If so that's good. If not I'd check to see if there was an alternate C/H/S translation for them.


Report •

#16
December 19, 2014 at 08:46:57
Hi Deveincaps.

Many thanks

I have a tower pc that I bought around 2000. It's not working and as I got a new drive some 3/4 years ago, I assume it is a serious potblem elsewhere, but I could try and use it to try and run one of the quantum drives.

I hope there are enough technicians around to give me a hand ressuscitating the machine... I'll start on it today and let you know what the problems are.

message edited by qim


Report •

#17
December 19, 2014 at 21:22:00
OK. I don't know if the drives were originally used just for storage or if they were bootable as the primary drive. If they were booting to an OS it was probably dos and they should boot up OK in whatever machine you put them in--as long as the bios sees them correctly--as dos doesn't care what hardware it's running on.

Report •

#18
December 20, 2014 at 09:34:35
Hi

I'll never make an engineer! I've opened up my old tower and managed to attach one of the Quantum drives without any trouble as the sockets are the same.

However, as I mentioned before this old computer was out of action and I cannot get anything on the screen. I expect the graphics card has had it. Is there any way of bypassing the graphics card so that I can get something on the screen of a laptop?

The other possibly good news is that I found a diskette which may have the dos OS. In any case, if I get the Quantum to work it is loaded with the OS.

Help....


Report •

#19
December 20, 2014 at 15:18:48
If you mean using the laptop screen as a monitor for the desktop I don't think that's possible or if it is it's not practical.

There could be any number of reasons why the desktop isn't booting up. You probably hear the fans and drives spinning up and see the LEDs flashing and you think it's working so therefore the lack of anything showing on the screen must be video related. That's not necessarily true. The fans and drives are powered separately from the motherboard so they often spin up even if the motherboard or power supply itself is bad.

When you start up the desktop do you hear any beeps? One short one is usually normal. Any other sequence or none at all indicates a problem. If the power supply has a 115/230 voltage switch make sure it's in the correct position (I've had that happen once or twice). DON'T GUESS and only move that switch with the power cord disconnected.

With the power cord removed temporarilly disconnect all the hard drives and remove any unneeded add-on cards. Then see if you get a posting or logo screen.

If possible swap in a known working compatible power supply and if it posts then.


Report •

#20
December 21, 2014 at 00:37:25
Hi Dave

When I start the PC I hear a longish peep followed by 3or 4 short rapid ones. After that there seems to be little noise coming from inside. I would have thought the HD would carry on with the usual noises of going backwards and forwards loading what it needs.

What do you mean by the switch being in tthe correct position? Do you mean a switch INSIDE the PC? I never touched anything that could change it, if it has one and the PC worked until a few months ago. The voltage here is 230/240.

I do have a problem with the cable that connects the PC to the monitor, I had a lot of trouble attaching it to the computer and had to force it suggesting something is wrong there. Unfortunately the monitor is a Philips that has one end of the cable deep inside it and I will have to get my car tools... to undo the thing. I will buy a new cable and see if that solves anything.

i will keep you posted.

Thanks for your help

qim

message edited by qim


Report •

#21
December 21, 2014 at 14:48:37
The switch I'm talking about would be on the back of the power supply near where the A/C cable plugs in. It's usually not a problem unless someone could have messed with it. It's just not something most people would check. Since you're getting beeps that switch won't be the problem anyway.

You need to check the motherboard or system manual for the beep codes. They can give a general idea of what the problem is.


Report •

#22
December 22, 2014 at 02:33:00
Hi Dave

Slowly, slowly...

I manged to get the old computer going (needed to clean contacts of graphics card) and placed the old drive in series. XP does not finish loading (it starts woith logo, etc, but then freezes) I expect that I should have the XP drive first rather than last, but if that is the case why does XP START loading?

message edited by qim


Report •

#23
December 22, 2014 at 02:57:14
UPDATE

I've now simply switched drives and a number of pisitive things happened. The name of the compny appeared, some software was mentioned and I believe loaded, then I got Microsoft SMARTDrive Disk Cache v2.10
Cache size 256k in Extended memory
room for 30 trackes in 17 sectors each

Please wait...

And I've been waiting for ages... and nothing else happens.

I guess I need to go into the SetUp but would not know what to do!


Report •

#24
December 22, 2014 at 07:42:13
Hi

The other Quantum drive simply : Boot Failure!

On the assumption that the Quantum drives will not boot up and that the Hitachi being scasi is more complicated I looked at the Seagate to find that it has a label that says SWIFT 94355-150. There is webpage avbout this

http://216.23.170.205/Hard%20Drive%...

which mentions an St506 interface

"ST 506 is an interface, which was used both with RLL and MFM. There is serial connection from controller to disk. The ST 506 controller functions as a converter from the serial read/write head data to the 8 or 16 bit parallel bus."

Where does this leave me, please?

message edited by qim


Report •

#25
December 22, 2014 at 13:11:07
The seagate is the one you'd need the RLL controller card for. For now there's really no way to get it connected.

The smartdisk message with the other quantum must mean dos is starting to load from it. It might be hanging because it's got a different configuration in bios setup. The "17 sectors" may mean it's congured there as an MFM drive type as they had 17 sectors per track. What was the drive model of that one as maybe I can check to see if it has a bios translation that you could configure it as?

You say with the drives in different positions on the cable that XP started loading and then stopped. Without the second quantum drive attached does XP boot up OK? If so and if the motherboard has 2 IDE ports can you attach the quantum by itself to the second port? XP might boot up OK if its drive is on a separate cable. You might try that too with the other quantum drive that gives the 'boot failure' message. As long as XP boots you may be able to view the contents of the other drive.


Report •

#26
December 22, 2014 at 13:39:03
"The "17 sectors" may mean it's congured there as an MFM drive type as they had 17 sectors per track. What was the drive model of that one as maybe I can check to see if it has a bios translation that you could configure it as?"

That is the Quantum ProDrive LPS

"Without the second quantum drive attached does XP boot up OK?"

Yes, once I sorted out the graphics card the computer works fine with the XP disk.

"If so and if the motherboard has 2 IDE ports can you attach the quantum by itself to the second port?"

Dio you mean try the Quantum alone in both connectors, one at a time?


Report •

#27
December 22, 2014 at 14:02:38
Have the xp drive on one motherboard IDE connector (the 'primary') and the quantum on the other motherboard connector (the 'secondary'). See if XP will boot that way and if so, if it can read the quantum drive. Often a cd or dvd drive will be attached to the secondary IDE port. If so you can temporarily disconnect it and attach the quantum in its place.

IF THAT DOESN'T WORK, there is a bios drive translation for the quantum LPS 105AT. It's:

cylinders 755
heads 16
sectors per track 17

You'd need to go into bios setup and choose a user defined drive type and enter those figures in the appropriate places. There will probably be other setting for it like write precomp but they won't matter since it's not actually an MFM drive. You have to make sure you're configuring the quantum drive and not the XP drive.

Many newer computer won't even allow for a 'user definable drive type'. If that's the case with yours then you won't be able to do that. It's kinda complicated anyway and hopefully if you get xp to boot up with the quantum on the other connection you'll be able to view it that way.

message edited by DAVEINCAPS


Report •

#28
December 22, 2014 at 14:42:50
Hi Dave

I've started Xms already and afte dinner, I don't want to chance messing verything up... so, I'll wait till tomorrow with a clear head!

Many thanks... and Happy Xmas!

message edited by qim


Report •

#29
December 23, 2014 at 01:16:27
Hi Dave

The Asus MB has 3 vertical sockets (1 blue, 1 black, and a slightly shorter lower one). At the moment, the HD is connected to the blue one on the left; the black one leads to a CD drive; and the shorter right-hand one to the disketted drive. There are some blue switches above. I've googled for an image but can't find one. I could send you a photo of the motherboard.

So, for the FIRST paragraph of your last post, I assume that I use the same MO socket (the blue one) and attach the first plug in the wide lead that comes out of it (is that the primary?) to the XP and the plug at the end of the lead (the secondary?) to the Quantum ProDrive LPS

I'll wait for your comments on this before advancing with the rest of the instructions.

Thanks

message edited by qim


Report •

#30
December 23, 2014 at 01:37:32
The motherboard IDE ports are usually labled as primary and secondary. Each one of those can accomodate 2 drives. It sounds like the blue one is the primary and the black one connected to the cd drive is the secondary.

I assume you had both the XP drive and the quantum drive on the same cable. Instead of that, temporarilly disconnect the cdrom cable and connect that cable to the quantum so that the xp drive is on one cable and the quantum drive is on the other. You'll probably have the quantum drive sitting there loose so be careful where you set it. You don't want its circuit board touching any metal. After you get it connected see if it'll boot to xp and if so, if it can see the quantum drive.

If the cable you're using has 2 connectors on it, connect the drive to the connection on the end. Sometimes it doesn't matter which you connect it to but for a single drive it'll usually always work on the end connection.


Report •

#31
December 23, 2014 at 02:08:49
"You don't want its circuit board touching any metal."

That's interesting because most HD have a metal cover ABOVE and naked bits underneath, where they will sit on some metal base...

Should I put them upside down, with the covered surface BELOW?


Report •

#32
December 23, 2014 at 02:47:26

Attached drives as suggested

1st try: went directly into set-up: i exited without changes; Windows loaded all the way; started looking for new hardware (Quantum drive). However, when I checked in My Computer the drive was not there.

2nd try: black screen after initial checks of memory etc: had to abort

3rd try: Message about previous problem offered list of stsrts I chose start normally; loaded Windows but My Computer did not respond;
had to abort

4th try: black screen again

5th try:Chose "Last known good configuration" but ended up with black screen

6th try: This time I chose "Start normall" but again black screen

+++

On all tries that could be seen it said
Detecting secondary Master: Press F4 to skip

UPDATE:

I managed to load Windows in Safe Mode and look at My Computer: the Quantum drive is not there


Everything look good in Device Manager, but only ONE disk drive. It does not recognize the Quantum

message edited by qim


Report •

#33
December 23, 2014 at 14:57:17
On the 'Detecting secondary Master: Press F4 to skip' did you press F4 or leave it continue? If you hit F4 the bios would have ignored it and windows wouldn't have seen it.

Check its jumper settings here:

http://insight.actapricot.org/insig...

I assume it was set as 'single' but make sure since it's the only drive on the cable.

Also, what kind of IDE cable are you using for the quantum? Most newer computers need the 80 wire and some of those assume the drive is jumpered as CS (cable select) where the drives position on the cable determines whether it's master or slave. That's less likely to be the case if you're using a 40-wire cable and it looks like those quantums can't be configured for CS. Both the 40 and 80-wire cables have a 40 pin connection. The additional wires on the 80-wire have a coaxial shielding affect thus giving a better signal. There's some pictures and info here:

http://www.mikeshardware.com/howtos...

If jumpers and cables are OK I guess the next step would be to go into bios setup and see if you can set a user defined drive type. If so use the information I posted in # 27 above. If your computer it too new to use drive types then I don't think there's going to be any way to use it to view the quantum. You'd need to try to find something older--a 486 or maybe a pentium I.


Report •

#34
December 24, 2014 at 02:22:13
Hi Dave

I hope your Xmas is in full swing! Merry Xmas!

Now to my problem:

No, I did not press F4.

I can´t quite understand what I am supposed to do with the "jumper settings" (which I understand to be the pins). Mine are in a different location and there are 3 rwos of 2 pins each marked from top to bottom, DM,SP, DS. One of the pins seems to be bent and I am not sure how you can change their position as they appear to be fixed. THis is a picture of the pins:

http://postimg.org/image/irxoqpibj/

Regards

UPDATE

From the looks of it the cables are 40wire. The one connected to Quantum says (maybe ~with mistakes in reading)

HUNS FU RJ 2651 E97252 (covered by connector) 105ºC 300V 28AWS 911823-713

If you like I can give you what's written on the other (primary?) but what I noticed is that it says 150V rather than 300V like the above

message edited by qim


Report •

#35
December 24, 2014 at 16:50:39
It's showing no pins jumpered meaning it's configured as a slave drive--that is a second drive on the cable. The DS pins should be jumpered for a 'single' configuration.

Yeah, the one pin is bent. You should be able to gently nudge it back in place with a small flat blade screwdriver or needle nose pliers.

The jumpers it uses are smaller than the jumpers used on motherboards but you may want to check the other drives--especially the other quantum--and see if they have a jumper the same size you can borrow.


Report •

#36
December 25, 2014 at 00:19:33
Hi Dave

I am a bit lost...

The drives were always single drives in each computer. I never had two drives in any of them, so I cannot understand why you say they were slave drives.

Does the bent pin make any difference, if I just leave it as it is?


I will send you a picture of the other Quantum, later on, as the pins appear to be smaller.There are 3 pairs and the bottom one has a sleeve enclosing the two pins.

Is that what you men by jumpered?


Report •

#37
December 25, 2014 at 01:17:20
Hi Dave

I hope this photo of the other Quantum shows enough.

http://postimg.org/image/7i8p0aix7/

UPDATE

I straightened the pin and transfered the "jumper" from one drive to the other (same position). In fact, the pins are shorter in the one that had the bent pin.

I put it back in the computer, but the drive still does not show in "MY Computer". May be I have to jumper the pins differently.
At the moment, the black "jumper is over the two parallel DS pins

The XP is connected to the blue Mobo socket and the Quantum to the middle black socket. Should I try both to the same socket?

message edited by qim


Report •

#38
December 25, 2014 at 22:43:31
It's possible the drive might be seen in the old computer even if it was incorrectly jumpered as slave or maybe the jumper was there but fell off since the time the drive was removed. I was just going by the specs for the jumper configuration.

I had glanced at a similar quantum drive I had and saw the jumpers were smaller. I thought they'd be the same for all their drives of similar age. It's possible the jumper you swapped isn't making the connection since you say it's larger. Or maybe the problem is elsewhere.

You can try connecting them both on the same cable but I thought you tried that already and that's when XP stalled when booting up. If you do try again you should probably take the jumper off again since it'll be a slave drive.

Is this the same quantum that partially booted up in # 23? I assume in that case you removed the cable from the xp drive and attached it to the quantum? Try that again but this time have DS jumpered. And when it starts loading the files from the hard drive hit CTRL C. That should stop autoexec.bat. It'll give some message about aborting loading those commands or continuing. Choose to abort. I'm wondering if maybe that smartdrive caching program is causing a problem. If we can stop it from loading maybe it'll leave you at a dos prompt and you can take a look at what's on the driver. Don't use a USB keyboard for that (if that's what you got).


Report •

#39
December 26, 2014 at 02:37:51
having afurther look at the Quantum drives. The pins in the ProDrive 210A are definitely taller than in the ProDrive LPS. The little black jumper I took out of the first fits into the second but I am not sure that it creates the jump. One side has two little holes; the other you can see a wire running across. I fitted it with the holes down, i.e. the holes going into the pins. When I fit it in the 210A the top of the pins sick out of the top; in the LPS they don't.

So, I will move to the next step that you suggested

message edited by qim


Report •

#40
December 26, 2014 at 03:46:55
Hi

Now, I've tried everything and get BOOT Failure in both drives. I am so cinfused that I can't understand what I did in pst #23 above. Could it be that I had both drives on the same cable with the fist connectot in the XP and the Quantum in the last?

I am getting warnings about CPU speed; that last boot hung for improper CPU speed. There is also a warning that to make changes to the forst 4 fields (that include CPU speed) the Mobo must be set to jumper free mode... (all Chinese to me!)


AND THE GOOD NEWS:

I found the missing jumper in thepacking...

message edited by qim


Report •

#41
December 26, 2014 at 14:31:20
The cpu warnings may mean the cmos battery is weak and not holding the bios setup information. The cmos battery is usually the silvery-looking thing on the motherboard about the size of a nickel coin. When it's replaced you need to go into bios setup and set the date and other settings although sometimes the 'default' setting works OK. The problem with some of those Asus boards is they'll tell you the cpu speed isn't set up right but it won't tell you what it should be. Their auto detect cpu function isn't the best.

I'm not sure what could have happened in # 23 that isn't working now. I guess you can try various connections but the way I described should be the way it would be seen.

I'm beginning to think the only way is to find an older computer and set them up on it.


Report •

#42
December 27, 2014 at 09:57:53
Hi Dave

You are right, of course.

I've already found an old 486 40Mhz which I am going to fetch tomorrow.

I'll keep you posrted.


Report •

#43
December 28, 2014 at 00:39:03
That's good. First try identifying the drive as AUTO in bios setup. If that doesn't work use the translation I mentioned in # 27. You may need to experiment a little as setting up a hard drive on those older ones can sometimes be tricky. Make sure the jumpers are correctly set.

You may need to boot with a floppy dos bootdisk if the drive is seen but doesn't boot. If it's an installation disk be sure not to do the install else it might overwrite what's on the drive.


Report •

Ask Question