DOS - Modem Failed INternal Loopback Test

October 22, 2010 at 14:38:33
Specs: DOS 3.31, 80286 / 1024Kb
I have a Compaq Deskpro 286e with a 40MB HD (purchased 1989) that is dedicated to communicate with a remote Honeywell Building Management System W7505 (purchased 1989). All was working fine.

The CMOS battery (Dallas DS1287) recently failed rendering the box useless. I just replaced the battery with a Dallas DS12887+. I ran the SETUP program from the Compaq User Diagnostic Disk, and with some effort, was able to get the machine running again.

I ran the “TEST” program from the User Diagnostic disk, which indicated “1 Modem(s) – 2400 baud COM2 at IRQ?”. This obviously raised a question – IRQ should be “3”. I continued to test system hardware with this same diagnostic tool, and received a DOS error message 1201-09: “Modem failed internal loopback test – Interrupt circuit failure”.

The modem is a Cardinal 2450, and was working fine before the battery replacement. I don’t recall if there was a software disk with the modem originally, however, I can’t seem to locate one now. The modem did come with an application called “Bitcom” however it wasn’t used.

Does it appear that coincidentally the modem failed, or is there a configuration issue?

Your help is most appreciated…


See More: DOS - Modem Failed INternal Loopback Test

Report •

#1
October 22, 2010 at 17:47:54
Go back into cmos/bios setup and see if you can assign a particular IRQ to that com port.

Real men don't use AntiVirus; they just reformat


Report •

#2
October 22, 2010 at 23:11:53
I think on that 286 mobo the COMs are all hardware.

I assume the modem is internal, plugged into an 8 bit slot.

I would re-seat the modem. While it's out check for jumpers & DIP switches and jiggle them around. Don't lose track of the settings or you're sunk.


=====================================
Life is too important to be taken seriously.

M2


Report •

#3
October 23, 2010 at 04:20:12
DAVEIN CAPS and Mechanix2Go - Thank you for your response.

The SETUP program is very limited... You can define Floppy and fixed drives, Powee up Num lock on start, and security passwords - that's it... Can't define IRQ in Setup.

The modem is a Cardinal MB2450 Internal Modem. I did not configure the modem in any way (should I have?). It came with an application called "Bitcom" however, this is not used. As indicated earlier, when I ran the "Test" from the Compaq User Diagnostic Disk-1, the results indicated "1 Asynchronous Communications Interface(s) COM1 at IRQ4". and "1 Modem(s) - 2400 baud COM2 at IRQ?". I ran the hardware diagnostics from the same test and all components passed except the modem. I received the following message:
"Error Testing Modem at COM2, IRQ?
18:08:05
Error 1201-09
Modem Failed Internal Loopback Test
Interrupt Circuit Failure"

I pulled the modem card and cleaned the contacts with an eraser; and gently pushed down any chips that were in sockets.

There are no switches on the card and two Switches on the Motherboard - SW-1 with 6-DIPS and SW-2 with 8-DIPS. I played with alternating Dips 4&5 of SW-2, which the Systems Overview Manual indicates - "Selects the primary (COM1) and secondary (COM2) address for the serial interface, When to change - To change the integrated serial interface to COM2 when adding an additional serial device addressed as COM1. For example a modem”. Unfortunately I went through each permutation of the two switches and continued to get the error message...

This problem occurred after changing the CMOS Battery. I am wondering if the replacement battery is compatible - would you know anything about this. There appear to be several versions of the DS12887 chip specified on the Dallas datasheet. My replacement is the DS12887+.

Also, I had problems getting the system to recognize the HD after replacing the battery. Could his be an issue? Here’s what I did:

I opened the case and first blew out any dust on the board. There wasn’t much, however, I always start with housekeeping. The compressed air can had a little moisture in it (as normal) and at the time, I didn’t think much about it. Could this have potentially caused a short – or moved a particle across a circuit to result in this condition?

I carefully removed the old chip and installed the new, entered the SETUP application, made the appropriate date and time entries, identified the HD as “Type 43” (Non-Compaq 40MB) and rebooted the box. I received the message “missing operating system”. Is this typical? Why would I get this message after updating the SETUP?

Using the Compaq MS Startup disk, I confirmed the content on the 40MB HD appeared to still be in tact. I ran FDISK, and the HD looked fine (Partition - C:1; Status - A; Type - PRI DOS; Start - 0; End - 978; Size - 979; Total disk space is 804 Cylinders).

I updated the OS (DOS 3.31) and Master Boot Record (MBR), with the original Compaq OS Disks (MS-DOS" VER 3.31 - 082489 - REV 5) and still no fix. In an effort to avoid reformatting the HD, I finally tried an old version of Norton Desktop v 1.0 to attempt an “emergency fix”, and I was now able to boot from the HD. I’m not sure what the Norton product did to get the HD to be recognized, but it seemed to work… I have experienced a couple of other intermittent quirky things, and though the tests don’t indicate an OS problem (other than the Interrupt circuit failure), I’m not sure I have full confidence in the system…

Any suggestions you could provide would be greatly appreciated…


Report •

Related Solutions

#4
October 23, 2010 at 23:00:03
The modem needs to be at a different com port than what is selected for the motherboard. The IRQ should be unique too, although sometimes you can get away with sharing them with other hardware.

The 'missing operating system" on a drive you know is OK is usually because you've selected the wrong drive type. There will be 2 or 3 types around 40 meg, the most common being type 17. If you're sure it was originally type 43 then that's not the reason. But if norton fixed it then I guess you're OK.

Real men don't use AntiVirus; they just reformat


Report •

#5
October 24, 2010 at 07:57:21
Hello DAVEINCAPS:

Thank you for your response.

As it turned out I made a mistake in identifying drive type. The box originally came with a 40MB drive which failed in the mid 1990s. I replaced the drive in 1996, and all has been well. When I ran into this problem, my instinct was to simply identify the drive as 40MB from recall, and not remove the drive and check its specs. The drive data is as follows:

IBM
Model: DALA-3540
Capacity: 540 MB (527 MB)
(1049 CYL, 16 HEADS, 63SEC/T)
P/N: 85G3847
FRU P/N: 82G5928 JLY-95
MLC: D61625

Another label reads:
85G3855 JASMINE 45-S/N
53X524 08859 EC D61614

Disk Type options available to me in SETUP are as follows:

“Disk Types supplied by COMPAQ are:
Type-1: 10 MB
Type-2: 20 MB
Type-4: 70 MB
Type-6: 30 MB
Type-12: 70 MB
Type-14: 30 MB
Type-17: 40 MB
Type-22: 40 MB
Type-25: 130 MB
Type-27: 84 MB
Type-28: 320 MB
Type-33: 110 MB
Type-35: 130 MB
Type-38: 300 MB
Type-41: 650 MB
XENIX USE
Type-42: 528 MB
NON-COMPAQ OS2
Type-43: 40 MB
Type-45: 100 MB
Type-47: 60 MB
Type-49: 650 MB
COMPAQ DOS, OS2
Type-54: 20 MB

Other fixed disk drive suppliers may supply types not listed above”


As a result, I ran SETUP and changed the Drive Type to "42". When I attempted to boot, I received the following message:

"Non-System Disk or Disk Error
Replace and strike any key when ready"


I tried to run FDISK from the OS Disk and got the same error... I then ran "Faststart", a Compaq Utility and received the following result:

View of HD is as follows:
Unit Size: 503.0 MB
Primary DOS Partition: 40.6MB
Extended DOS Partition" 0.0 MB
Drive: C
Unit: 1
MB: 40.6
Percent: 8.1%
Active

System Configuration:
Diskette Drive: 1.2M 5.25 inch
Fixed Disk: 503.0 MB Type 42

Can you provide any guidance?

All of this started by changing the RTC. I keep wondering if the DS12887+ is the correct replacement for the original DS1287 chip. I am seeing the DS12887 to be the replacement. Could this have caused the origincal Modem IRQ issue?

Booch


Report •

#6
October 24, 2010 at 14:43:47
"When I ran into this problem, my instinct was to simply identify the drive as 40MB from recall, and not remove the drive and check its specs."

If you never changed the drive parameters (i.e.-the drive geometry), the machine would still think it had a 40MB drive in it.

"All of this started by changing the RTC. I keep wondering if the DS12887+ is the correct replacement for the original DS1287 chip. I am seeing the DS12887 to be the replacement. Could this have caused the origincal Modem IRQ issue?

Possibly...you could still revive the DS1287 (assuming you still have it) if you find out that's the case:

http://www.mcamafia.de/mcapage0/dsr...

"Channeling the spirit of jboy..."


Report •

#7
October 24, 2010 at 22:12:47
As near as I can tell, the trailing "+" or "A" on the battery part number indicates the device is lead-free. Page 21 here:

http://pdf1.alldatasheet.com/datash...

So you should be OK with what you have.

I was wondering if your dos 3.31 could even see a partition of 500 meg as 3.3 has a maximum partition size of 32 meg. But apparently starting with 3.31 the 2 gig maximum for FAT16 was possible. But as mentioned above, changing the drive type isn't going to change the 40 meg partition that's already on it.

You can probably setup an extended partition with FDISK using the rest of the space and then create a virtual drive within that partition. Or just delete the 40 meg partition and start over.

I'm still not sure what the problem with the modem is, as long as there's no COM port conflicts. Unless it's PnP, if the modem has no jumpers or switches on it, it must be hardwired to a certain port and IRQ. PnP wouldn't do you any good with DOS. You may end up having to get another modem.

Real men don't use AntiVirus; they just reformat


Report •

#8
October 25, 2010 at 03:28:49
HI DAVEINCAPS:

Thank you for your confirmation of the "+" to be "lead free". That hopefully removes one variable...

I checked the modem as directed, and I did find 3-jumpers at the bottom of the card. There are three sets of three pins. Jumpers are placed on pins 1&2 of each set of three pins.

I also entered SETUP and changed Drive Type from 42 (528MB) to 17 (40MB), 22 (40MB), and back to 43 (40MB) repectively. Here are the results:

Type 42 (528MB): Non-system Disk Error
Type 17 (40MB) Error loading operating system
Type 22 (40MB): Non-system disk error
Type 43 (40MB): Booted fine to Drive C

Ran TEST from User Diagnostic Disk and modem still shows as "COM2 at IRQ?", and still failed internal loopback test.

I tried to boot the system from the Compaq MS-DOS Operating System Disk, and again received the "Non-system Disk Error" message. I tried to run Norton Disk Dr. from the floppy as I had done at the start of this process, and also received the “Non-system Disk error" message.

I ran Norton Disk Dr. from the HD to diagnose the MS-DOS diskette and everything appears to be fine...

It appears that there have been coincidental cascading hardware and software failures that I can't explain...

Any further thoughts?

Booch


Report •

#9
October 25, 2010 at 16:05:14
The drive types are really fussy. When you partition (FDISK) a drive based on a certain drive type it often will only boot up when set to that drive type. That's because the drive type determines where the boot sector is.

If you're having problems booting with the floppy disk then likely either the drive is dirty or bad or the disk is bad.

Not sure about the modem. You should probably google the part number and see if you can find the jumper settings. It might be here:

http://www.resoo.org/docs/_hardware...

Real men don't use AntiVirus; they just reformat


Report •

#10
October 25, 2010 at 16:25:57
Hi DAVEINCAPS:

Many thanks for your follow-up and resource link!

I found data and settings for both the Modem and MB>

With respect to the floppy issue - I am finding that the drive will work with some disks but not with others...

What would you recommend to clean the drive - compressed air?


Report •

#11
October 25, 2010 at 17:11:53
Yeah, pull the drive out and remove its cover, if necessary. Then blow out all the dust. Dab a little (very little) grease--axle, lithium even vasiline--on the drive gear, if necessary. Use a q-tip and windex or alcohol and wipe the heads.

Real men don't use AntiVirus; they just reformat


Report •

#12
October 26, 2010 at 05:38:06
Thanks DAVEINCAPS!

Will try this.

Also, I was provided the following drive geometry data from another senior tech. I don't have the skill to interpret a lot of this info - does this provide any insight to you based on prior discussion?

Booch


Report •

#13
October 26, 2010 at 05:38:48
Drive Geometry:

D A L A - 3 5 4 0 5 4 1 / 5 2 8 M B IBM
Native| Translation
------+-----+-----+-----
Form 3.5"/SLIMLINE Cylinders | 1049| 1024|
Capacity form/unform 541/ MB Heads | 16| 16|
Seek time / track 12.5/ 4.0 ms Sector/track | 63| 63|
Controller IDE / ATA2 FAST/ENHA Precompensation
Cache/Buffer 96 KB SEGMENTED Landing Zone
Data transfer rate 4.000 MB/S int Bytes/Sector 512
11.100 MB/S ext PIO3
Recording method RLL operating | non-operating
-------------+--------------
Supply voltage 5/12 V Temperature *C 5 55 | -40
Power: sleep 0.8 W Humidity % 65 90 | 5 95
standby 0.8 W Altitude km -0.300 3.000| -0.300 12.000
idle 2.6 W Shock g 10 | 75
seek 5.2 W Rotation RPM 4500
read/write 4.5 W Acoustic dBA
spin-up W ECC Bit ON THE FLY
MTBF h 350000
Warranty Month
Lift/Lock/Park YES Certificates CSA,EEC,FCC,IEC380,IEC435,...


Report •

#14
October 26, 2010 at 13:01:46
The drive type geometry can't exceed the physical specs of the hard drive--the cylinders/heads/sectors per track. Otherwise the bios can send the heads looking for cylinders that don't exist and cause damage to the drive.

When a drive translation is used, the total translated sectors must be less than the total physical sectors. The total physical sectors is the product of the physical cylinders X number of heads X number of sectors per track. And I think the translation had to acceptable to the drive--you couldn't just use any C/H/S numbers whose product was less than the maximum. A lot of early IDE drives had translations using 17 sectors per track as that was the standard for MFM drives on which most of the drive types were based.

It looks like that drive has a geometry of 1049/16/63 and a translation of 1024/16/63. The 1024 figure is the highest the old bios' could accomodate so they had to ignore the last 25 physical cylinders on the drive. And there's not another translation using those old bios' that would give a near 500 meg capacity.

When you don't have a drive type that'll see the drive's entire capacity you have to settle for a type that has less cylinders, heads or sectors or a translation whose total sectors don't exceed the drive's total sectors.

About the time 386's came along most bios' had a 'user definable drive type' where you could input the c/h/s figures which made things a lot easier.

I'm not sure if your drive type list has the cylinders, heads and sectors for each type. But they're listed in this pdf:

ftp://home.cbvk.cz/docs/hardware/upgrading&repairing-pcs/appa.pdf

on pages 71 and 72. Drive type 42 should work with that drive but you'd need to repartition, format and reinstall the OS --dos 3.31 or above.

Real men don't use AntiVirus; they just reformat


Report •

#15
October 26, 2010 at 13:56:06
Hi DAVEIN CAPS:

I downloaded the PDF - Thank you.

This is quite interesting. If I am able to resurrect the OS diskettes, I will do what you suggest to take advantage of the drive size.

In light of what appears to be a rash of cascading hardware and software failures, I have been copying original LD OS diskettes to folders on the HD and then copying these over to several old HD data diskettes I reformatted.

FYI - I attempted to connect to the Honeywell Building Control this morning. The communications software only allows for a modem on COM1 or COM2. It is set for COM2. When I initiated the command to receive status and history from the control, the modem initialized; received an audible dial tone; dialed the facility #; initially connected and then lost connection. I retried the process and was able to connect a bit longer, however, got a security code mismatch and the system terminated again. When all of this started, I reinstalled the Honeywell software into an alternate directory to see if the instance I was using was corrupt. Both installs produce the same result.

I have received recommendations to try to get another modem at this point. I will be looking on-line for a DOS based internal card. Any suggestions on a particular source you might have had good luck with?

Once again. many thanks for your assistance.

Booch


Report •

#16
October 26, 2010 at 14:59:58
Probably something that includes dos setup software. For a US Robotics and maybe others you can probably download the software from their site.

Obviously ISA and not PCI, not PnP or at least switchable between PnP and non-PnP. There's hardware and software modems. For dos you need a hardware modem. Software modems rely more on the OS and dos doesn't have that capability. Within the hardware modem group I'm not sure if they'll specify a minimum CPU or OS but you should find out before getting one.

I doubt you'll find a new one so you'll probably have to look on ebay.

Real men don't use AntiVirus; they just reformat


Report •

#17
October 26, 2010 at 16:32:43
DAVEINCAPS et.al.:

I very much appreciate your excellent, thoughtful and timely guidance and advice!

I will seek out an alternate modem.

I will report the final outcome once complete.

Thnaks once again for all your assistance.

Regards,

Booch


Report •

#18
October 26, 2010 at 18:02:20
You're welcome. Getting some of those old systems set up can be tough to do. Kinds like rebuilding a classic car. I hope it all works out.

Real men don't use AntiVirus; they just reformat


Report •

#19
November 11, 2010 at 09:57:00
Hi DAVEINCAPS:

I have pulled my 5.25 drive (Cannon MD5501), however, I can't seem to figure out how to get access to the heads for cleaning... Any suggestions?

Booch


Report •

#20
November 11, 2010 at 20:14:22
Oh, one of those. I can't say for sure but if you can get the cover off you'll have no problem cleaning them.

Real men don't use AntiVirus; they just reformat


Report •

#21
November 12, 2010 at 04:41:31
I've trid to locate an exploded view or schematic of the mechanical drive so I can see how these parts come together so I don't potentially damage anything - but have not been able to find anything. I even called an internet supplier that carried the drive - however, they wouldn't/couldn't help...

Any idea where such an item might exist?


Report •

#22
November 12, 2010 at 20:05:59
Sorry, no. The cover is usually easy to remove but I can't say for sure with any particular model. I've got a few 5.25 drives around here somewhere. I'll try to find them and see if I have that model.

Real men don't use AntiVirus; they just reformat


Report •

#23
November 13, 2010 at 03:57:04
Thanks!

Greatly appreciated.


Report •

Ask Question