Solved why won't my memory card eject from my camera?

February 13, 2014 at 12:03:10
Specs: Windows 7
Fujifilm Finepix S camera won't eject SD card. I have to pull it out.. I don't detect the lock engaging when I push it in.. The camera is not reading it either.. Says "No Card" message. It has always worked fine until today. I also tried a different SD card didn't work either.

See More: why wont my memory card eject from my camera?

Report •

February 13, 2014 at 14:35:43
✔ Best Answer
If both SD cards aren't working, it is likely something wrong with the card slot on the camera. Have you made sure that nothing is stuck in the slot? You might want to try to blow any dust out of it too. If neither of these work, then you should contact the manufacturer and have them replace the camera.

Report •

February 14, 2014 at 08:16:58
Thanks, I was afraid that was the case. I will go to Fuji's web site and see what they can do.. I also have a camera shop in town I may take it to also..

Report •
Related Solutions

Ask Question