Solved nikon coolpix s9500 camera wont recharge

September 25, 2013 at 11:14:59
Specs: Windows 7
Have nikon coolpix s9500. Just been on holiday to turkey. No problems with it. No problems after I got back, until battery was exhausted. Tried to recharge it, but it wont. Small green light does not light up either. Took charger with me to turkey but did not need to use it. Have tried removing battery & replacing it. Tried unplugging usb cable from charger & replacing it. Nothing. Rather concerned as I have only had camera for a few weeks.

See More: nikon coolpix s9500 camera wont recharge

Report •

September 25, 2013 at 13:19:17
✔ Best Answer
If the battery is completely dead it may take awhile before it even gets a minimal charge so keep it on the charger for several hours before you decide you have a problem.

If that doesn't fix it:

The charger you're using plugs into a wall socket and has a removable USB cable? Check the camera manual but I'm pretty sure the camera is designed to be charged through a USB port on a computer as well. You can try that and if it charges OK then the charger must be bad.

You say you tried removing the battery and replacing it. I don't mean to be dense but using the word 'tried' is confusing. Does that mean you replaced the battery and had the same problem or you tried to replace it but for some reason you couldn't?

If the above doesn't help then since you've only had it a few weeks it should be under warranty.

Report •

September 27, 2013 at 06:36:26
If the camera is only 2 weeks old, I would say you might take it back and get an exchange. No use keeping something that will be a continuous problem over the years.

HELP in posting on plus free progs and instructions

Report •

September 28, 2013 at 11:32:52
Thank you for replying to my query. Tried everything you said. Nothing. Will go the warranty route, but thank you so much for your informative & helpful suggestions. Much appreciated.

Report •

Related Solutions

September 28, 2013 at 21:00:48
You're welcome. I hope they get it fixed for you.

Report •

Ask Question