Solved Code 43 Error

Canon Powershot sx120 is point & shoot d...
June 30, 2010 at 23:17:53
Specs: Windows 7
I am having trouble connecting my Canon
Camera (Power Shot SX120) to my PC.
When I connect it, I get the following error
Device Type: Universal Serial Bus controllers
Manufacturer: (Standard USB Host Controller)
Location: Port_#0003.Hub_#0008
Windows has stopped this device because it
has reported problems. (Code 43)

I get the same message when I connect the
camera to a PC running Windows XP.
However, the camera loaded photos without
problems on my son’s MAC a few weeks ago
(and it also uploaded photos successfully once
to another PC running Windows XP around that
same time)

I have also seen this message:
Device Type: Portable Devices
Manufacturer: (Standard MTP Device)
Location: Port_#0002.Hub_#0004
Currently, this hardware device is not connected
to the computer. (Code 45)

I do not know what changed between the times
that I got the two different messages.
(It may have just been camera power turned off).
Code 43 definitely comes up more often than
Code 45)

I contacted Canon and they claim that it is a
problem with the drivers from Microsoft, and it is
not their (Canon’s) problem. They are willing to
check the camera if I mail it back to them, but I
am not completely convinced that the problem is
with the camera)

I tried uninstalling all of the USB controllers (and
they were automatically reinstalled upon
rebooting) but that did not solve the problem
I checked Microsoft for new drivers (according to
Canon, only drivers from Microsoft are used) but
Windows tells me that my drivers are up to date.

Are there any other suggestions?

Thank you.

See More: Code 43 Error

July 1, 2010 at 02:30:41
✔ Best Answer
Well, I believe that I found the source of the problem:
It was a cheap USB cable.
Once I tried using a another cable, everything worked fine.
I hope this saves someone else some aggravation.

Report •

August 8, 2010 at 03:18:07
I had this problem and the cause was also the cable, although being an original Canon cable. Changed the cable and everything was OK...

Report •
Related Solutions

Ask Question