Canon Powershot SD750: no images

May 10, 2011 at 16:15:40
Specs: Windows 7, PCLinux, plenty
Hi,
I have a Canon SD750 which has been great up till today. Now, when I turned it on the viewfinder had no image. The visual icons were showing. I charged the battery; no difference. I reformated the data card; no difference. I took a picture, and it didn't show in the viewfinder. I plugged it into the computer and downloaded the picture, and it shows all black on the computer as well.

It seems like the camera is not receiving images from the lens. The camera has been lightly used, and the only thing I can think of is that the last time I used it, when I downloaded the images I did some housekeeping and deleted folders via the computer. But I don't see how that would affect anything.

Anyone have any ideas on this? I would hate to lose this cam.

Thanks,
p.


See More: Canon Powershot SD750: no images

Report •


#1
May 15, 2011 at 10:56:11
Just a simple question...did you contact canon tech support on this?

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

#2
May 15, 2011 at 11:02:44
Hi XP,

Yes, because it's out of warranty it would be a $99 minimum labor charge.

But I remembered something that happened the week before I noticed it broke - the cam flopped over forward on my desk. So I said a prayer and pushed it over backward to reverse the damage. And it worked! ;)

For how long, I don't know, but I'm back in a camera.

BW,
p.


Report •

#3
May 15, 2011 at 11:13:01
lol, that was sure a stroke of luck...hopefully it keeps working for you.

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

Related Solutions


Ask Question